HP LaserJet 1018 :  foo2zjs - foo2hp - foo2xqx - foo2lava - foo2qpdl - foo2oak
Support for linux printer drivers
The fastest message board... ever.
 
LJ1018 does not print with CUPS [arch linux]
Posted by: senorsnor ()
Date: December 29, 2009 10:49AM

I use Arch Linux, and recently I upgraded to Cups 1.4.2. After upgrading, I installed new foomatic filters and foo2zjs etc. From the command line, everything seems to work:

[arvind@pussycat ~]$ usb_printerid /dev/usb/lp0
GET_DEVICE_ID string:
MFG:Hewlett-Packard;MDL:HP LaserJet 1018;CMD:ACL;CLS:PRINTER;DES:HP LaserJet 1018;FWVER:20051028;

and I can print a test page using foo2zjs-wrapper and cp-ing it to /dev/usb/lp0.

In Cups, however, I cannot seem to add the printer. I removed the old printer and tried to create it anew, but when I click Add Printer, it scans for local printers and only lists SCSI and LPT1 as an option. Before, it suggested USB as well.

I have no clue on how to add my printer now using Cups. I tried moving back the old /etc/cups/printers.conf (I had a copy), at least that shows the printer in Cups. Then I modified that printer to use "HP LaserJet 1018 Foomatic/foo2zjs (recommended) (grayscale)" for driver. The connection is set to "usb:/dev/usb/lp0", and I tried "usb://HP/LaserJet%201018" as well. With both connections, printing a test page puts a test page in the queue of the cups interface ("processing since ...") but it never actually prints.

Does anyone have any idea on how I can get my printer to work again? All help appreciated, thanks!



Edited 2 time(s). Last edit at 12/29/2009 11:41AM by rickrich.

Options: ReplyQuote
Re: LJ1018 does not print with CUPS [arch linux]
Posted by: rickrich ()
Date: December 29, 2009 11:58AM


Options: ReplyQuote


Sorry, only registered users may post in this forum.
This forum powered by Phorum.