Fuji Xerox CM205/CM215, Xerox WorkCentre 6015 :  foo2zjs - foo2hp - foo2xqx - foo2lava - foo2qpdl - foo2oak
Support for linux printer drivers
The fastest message board... ever.
color MFP 
Xerox WorkCentre 6015 Foomatic/foo2hbpl2 network printing does not work
Posted by: sss123next ()
Date: August 16, 2013 03:56PM

in cups admin console job have status
" processing since
Fri 16 Aug 2013 10:12:56 PM EEST
"Filter failed" "

in cups log i have following:

"
E [16/Aug/2013:21:48:11 +0300] [Job 35] Job stopped due to filter errors; please consult the error_log file for details.
D [16/Aug/2013:21:48:11 +0300] [Job 35] The following messages were recorded from 21:48:07 to 21:48:11
D [16/Aug/2013:21:48:11 +0300] [Job 35] Adding start banner page "none".
D [16/Aug/2013:21:48:11 +0300] [Job 35] Queued on "xerox" by "root".
D [16/Aug/2013:21:48:11 +0300] [Job 35] File of type application/vnd.cups-command queued by "root".
D [16/Aug/2013:21:48:11 +0300] [Job 35] Adding end banner page "none".
D [16/Aug/2013:21:48:11 +0300] [Job 35] time-at-processing=1376678887
D [16/Aug/2013:21:48:11 +0300] [Job 35] 2 filters for job:
D [16/Aug/2013:21:48:11 +0300] [Job 35] commandtops (application/vnd.cups-command to printer/xerox/application/postscript, cost 100)
D [16/Aug/2013:21:48:11 +0300] [Job 35] - (printer/xerox/application/postscript to printer/xerox, cost 0)
D [16/Aug/2013:21:48:11 +0300] [Job 35] job-sheets=none,none
D [16/Aug/2013:21:48:11 +0300] [Job 35] argv[0]="xerox"
D [16/Aug/2013:21:48:11 +0300] [Job 35] argv[1]="35"
D [16/Aug/2013:21:48:11 +0300] [Job 35] argv[2]="root"
D [16/Aug/2013:21:48:11 +0300] [Job 35] argv[3]="Set Default Options"
D [16/Aug/2013:21:48:11 +0300] [Job 35] argv[4]="1"
D [16/Aug/2013:21:48:11 +0300] [Job 35] argv[5]="job-uuid=urn:uuid:641119b3-46cd-3ede-7946-eadb3d0d2ab3 job-originating-host-name=localhost time-at-creation=1376678887 time-at-processing=1376678887"
D [16/Aug/2013:21:48:11 +0300] [Job 35] argv[6]="/var/spool/cups/d00035-001"
D [16/Aug/2013:21:48:11 +0300] [Job 35] envp[0]="CUPS_CACHEDIR=/var/cache/cups"
D [16/Aug/2013:21:48:11 +0300] [Job 35] envp[1]="CUPS_DATADIR=/usr/share/cups"
D [16/Aug/2013:21:48:11 +0300] [Job 35] envp[2]="CUPS_DOCROOT=/usr/share/cups/html"
D [16/Aug/2013:21:48:11 +0300] [Job 35] envp[3]="CUPS_FONTPATH=/usr/share/cups/fonts"
D [16/Aug/2013:21:48:11 +0300] [Job 35] envp[4]="CUPS_REQUESTROOT=/var/spool/cups"
D [16/Aug/2013:21:48:11 +0300] [Job 35] envp[5]="CUPS_SERVERBIN=/usr/libexec/cups"
D [16/Aug/2013:21:48:11 +0300] [Job 35] envp[6]="CUPS_SERVERROOT=/etc/cups"
D [16/Aug/2013:21:48:11 +0300] [Job 35] envp[7]="CUPS_STATEDIR=/run/cups"
D [16/Aug/2013:21:48:11 +0300] [Job 35] envp[8]="HOME=/var/spool/cups/tmp"
D [16/Aug/2013:21:48:11 +0300] [Job 35] envp[9]="PATH=/usr/libexec/cups/filter:/usr/bin:/usr/sbin:/bin:/usr/bin"
D [16/Aug/2013:21:48:11 +0300] [Job 35] envp[10]="SERVER_ADMIN=root@evil-desktop"
D [16/Aug/2013:21:48:11 +0300] [Job 35] envp[11]="SOFTWARE=CUPS/1.6.3"
D [16/Aug/2013:21:48:11 +0300] [Job 35] envp[12]="TMPDIR=/var/spool/cups/tmp"
D [16/Aug/2013:21:48:11 +0300] [Job 35] envp[13]="USER=root"
D [16/Aug/2013:21:48:11 +0300] [Job 35] envp[14]="CUPS_MAX_MESSAGE=2047"
D [16/Aug/2013:21:48:11 +0300] [Job 35] envp[15]="CUPS_SERVER=/run/cups/cups.sock"
D [16/Aug/2013:21:48:11 +0300] [Job 35] envp[16]="CUPS_ENCRYPTION=IfRequested"
D [16/Aug/2013:21:48:11 +0300] [Job 35] envp[17]="IPP_PORT=631"
D [16/Aug/2013:21:48:11 +0300] [Job 35] envp[18]="CHARSET=utf-8"
D [16/Aug/2013:21:48:11 +0300] [Job 35] envp[19]="LANG=en_US.UTF-8"
D [16/Aug/2013:21:48:11 +0300] [Job 35] envp[20]="PPD=/etc/cups/ppd/xerox.ppd"
D [16/Aug/2013:21:48:11 +0300] [Job 35] envp[21]="RIP_MAX_CACHE=128m"
D [16/Aug/2013:21:48:11 +0300] [Job 35] envp[22]="CONTENT_TYPE=application/vnd.cups-command"
D [16/Aug/2013:21:48:11 +0300] [Job 35] envp[23]="DEVICE_URI=ipp://192.168.0.1:631/printers/xerox"
D [16/Aug/2013:21:48:11 +0300] [Job 35] envp[24]="PRINTER_INFO="
D [16/Aug/2013:21:48:11 +0300] [Job 35] envp[25]="PRINTER_LOCATION="
D [16/Aug/2013:21:48:11 +0300] [Job 35] envp[26]="PRINTER=xerox"
D [16/Aug/2013:21:48:11 +0300] [Job 35] envp[27]="PRINTER_STATE_REASONS=none"
D [16/Aug/2013:21:48:11 +0300] [Job 35] envp[28]="CUPS_FILETYPE=document"
D [16/Aug/2013:21:48:11 +0300] [Job 35] envp[29]="FINAL_CONTENT_TYPE=application/postscript"
D [16/Aug/2013:21:48:11 +0300] [Job 35] envp[30]="AUTH_I****"
D [16/Aug/2013:21:48:11 +0300] [Job 35] Started filter /usr/libexec/cups/filter/commandtops (PID 4996)
D [16/Aug/2013:21:48:11 +0300] [Job 35] Started backend /usr/libexec/cups/backend/ipp (PID 4997)
D [16/Aug/2013:21:48:11 +0300] [Job 35] Sending stdin for job...
D [16/Aug/2013:21:48:11 +0300] [Job 35] update_reasons(attr=0(), s="+connecting-to-device")
D [16/Aug/2013:21:48:11 +0300] [Job 35] op='+', new_reasons=1, state_reasons=1
D [16/Aug/2013:21:48:11 +0300] [Job 35] STATE: +connecting-to-device
D [16/Aug/2013:21:48:11 +0300] [Job 35] Looking up "192.168.0.1"...
D [16/Aug/2013:21:48:11 +0300] [Job 35] hrDeviceDesc="Unknown"
D [16/Aug/2013:21:48:11 +0300] [Job 35] prtGeneralCurrentLocalization type is 0, expected 2!
D [16/Aug/2013:21:48:11 +0300] [Job 35] backendWaitLoop(snmp_fd=5, addr=0x7fb3843f0fe8, side_cb=0x7fb383fe0c10)
D [16/Aug/2013:21:48:11 +0300] [Job 35] Unable to auto-configure PostScript Printer - no bidirectional I/O available!
D [16/Aug/2013:21:48:11 +0300] [Job 35] PID 4996 (/usr/libexec/cups/filter/commandtops) stopped with status 1.
D [16/Aug/2013:21:48:11 +0300] [Job 35] Hint: Try setting the LogLevel to "debug" to find out more.
D [16/Aug/2013:21:48:11 +0300] [Job 35] PID 4997 (/usr/libexec/cups/backend/ipp) exited with no errors.
D [16/Aug/2013:21:48:11 +0300] [Job 35] End of messages
D [16/Aug/2013:21:48:11 +0300] [Job 35] printer-state=3(idle)
D [16/Aug/2013:21:48:11 +0300] [Job 35] printer-state-message="Filter failed"
D [16/Aug/2013:21:48:11 +0300] [Job 35] printer-state-reasons=none

"

this happened when i trying to print via network, on local printer i have succesfully printed test page with colors, but i want to setup printer as network printer, i can provide any debug info needed ...



Edited 1 time(s). Last edit at 08/17/2013 07:43AM by rickrich.

Options: ReplyQuote
Re: Xerox WorkCentre 6015 Foomatic/foo2hbpl2 (recommended) (color, 2-sided printing) network printing does not work
Posted by: sss123next ()
Date: August 16, 2013 05:59PM

it's test page from internal cups console, but via network, same works fine for local printer.

i have done following:

on local machine add printer via cups web console (on port 631), succesfully printed test page,
when on remote machine added ipp printer with correct url (ipp://host:631/printers/name), and than i trying to print test page get error in first post.



Edited 1 time(s). Last edit at 08/16/2013 06:03PM by sss123next.

Options: ReplyQuote
Re: Xerox WorkCentre 6015 Foomatic/foo2hbpl2 (recommended) (color, 2-sided printing) network printing does not work
Posted by: rickrich ()
Date: August 16, 2013 06:26PM

Read this!

Is it NOT my problem.

Options: ReplyQuote
Re: Xerox WorkCentre 6015 Foomatic/foo2hbpl2 network printing does not work
Posted by: sss123next ()
Date: August 18, 2013 05:01AM

i read page from link, it's not related to my problem, looks like i have posted incorrect log in first post, please look at this: http://pastebin.com/Kz0TMiS8

Options: ReplyQuote
Re: Xerox WorkCentre 6015 Foomatic/foo2hbpl2 network printing does not work
Posted by: rickrich ()
Date: August 18, 2013 07:44AM

D [18/Aug/2013:11:58:21 +0300] [Job 60] Cannot process "/var/spool/cups/d00060-001": Unknown filetype.
D [18/Aug/2013:11:58:21 +0300] [Job 60] Process is dying with "Could not print file /var/spool/cups/d00060-001
D [18/Aug/2013:11:58:21 +0300] [Job 60] ", exit stat 2

It is NOT my problem. Maybe CUPS or network.

Options: ReplyQuote
Re: Xerox WorkCentre 6015 Foomatic/foo2hbpl2 network printing does not work
Posted by: sss123next ()
Date: August 18, 2013 09:09PM

thx for info, but i have no idea at all how to fix it and where to search ..., maybe you can point me to right direction ?

Options: ReplyQuote
Re: Xerox WorkCentre 6015 Foomatic/foo2hbpl2 network printing does not work
Posted by: rickrich ()
Date: August 18, 2013 10:41PM

I don't know. I did a remote print from a system running Fedora 18 to a system running Fedora 19 using the instructions I gave you (see "Read this!") with no problems.


Options: ReplyQuote
Re: Xerox WorkCentre 6015 Foomatic/foo2hbpl2 network printing does not work
Posted by: sss123next ()
Date: August 21, 2013 02:02AM

ok, thx for reply, i am on gentoo, and have not X at all on server also have not gnome on desktop, so can't use gnome tools, but it should not be problem, i will continue searching.

Options: ReplyQuote
Re: Xerox WorkCentre 6015 Foomatic/foo2hbpl2 network printing does not work
Posted by: sss123next ()
Date: August 23, 2013 11:50PM

still no luck at all, can you please post versions of: cups, cups-filters, foomatic-db-engine, foomatic-db, foomatic-filters, ghostscript-gpl, poppler, i believe that is some king of version incompatibility, but have no changes at all in all combinations that i have tried...

Options: ReplyQuote
Re: Xerox WorkCentre 6015 Foomatic/foo2hbpl2 network printing does not work
Posted by: rickrich ()
Date: August 24, 2013 04:21AM

$ yum list cups cups-filters foomatic-db-engine foomatic-db foomatic-filters ghostscript poppler

Installed Packages
cups.x86_64                          1:1.6.3-4.fc19                    @updates 
cups-filters.x86_64                  1.0.36-2.fc19                     @updates 
foomatic-db.noarch                   4.0-38.20130604.fc19              @anaconda
foomatic-filters.x86_64              4.0.9-3.fc19                      @updates
ghostscript.x86_64                   9.07-12.fc19                      @updates
poppler.x86_64                       0.22.1-4.fc19                     @updates



Edited 4 time(s). Last edit at 08/24/2013 04:30AM by rickrich.

Options: ReplyQuote
Re: Xerox WorkCentre 6015 Foomatic/foo2hbpl2 network printing does not work
Posted by: sss123next ()
Date: August 24, 2013 06:09AM

ok, thx, oldest foomatic-filters i can install is 4.0.17, also oldest poppler in repo is 0.22.2, cups and cups-filters have same versions, downgrading ghostscript changes nothing.

Options: ReplyQuote
Re: Xerox WorkCentre 6015 Foomatic/foo2hbpl2 network printing does not work
Posted by: sss123next ()
Date: August 24, 2013 05:00PM

also, i have tested local printing via lpr, it worked fine

Options: ReplyQuote


Sorry, only registered users may post in this forum.
This forum powered by Phorum.