General foo2zjs :  foo2zjs - foo2hp - foo2xqx - foo2lava - foo2qpdl - foo2oak
Support for linux printer drivers
The fastest message board... ever.
 
Which kernel version ?
Posted by: vmirce ()
Date: September 29, 2008 05:45AM

Medical equipment attached to a linux box came with some kind of customized-RedHat9 version to wich I don't have access, passwords and stuff, no console access... Very few kinds of printers are predefined, most of which are not produced any more, and can't be found on the market.
It's runinng on a 2.4.* kernel version, so it would be nice to know: is the present foo2zjs compatible with this kernel ? It's the only issue that bothers me, because i have idea to solve te problem with access restriction, and will share with readers o this forum :
1. I plan to attach this HDD as a slave to a regular machine whit a regular Linux.

2. Copy and gunzip+untar the script to /slavedisc/somedir/with/foo2zjs.

3. Add this lines of a shell script to (for example) /etc/rc.boot, or similar :

######### Begining of example lines ############
cd /somedir/with/foo2zjs
make
make install
make install-hotplug
make whatEverIsNeeded
cd
# Following is to guarantee that these lines will be executed only once :
mv /somedir/with/foo2zjs /someother/foo2zjs/directory
######### End of example lines ############

4.Connect the HDD back to it's original box.

This way the driver will be installed during the boot.So, as i mentioned, it's the kernel 2.4.* compatibility issue that worries me...

The second solution that came up is :
1. Install original Red Hat 9 on some computer
2. Isntall foo2zjs on that one
3. Make a tarball with all the needed files
4. Copy all of these files to the destination disc.
But there is a problem, i dont know which files are nesecery, and where are all of them copied during the install (which goes where) ?

If foo2zjs is not compatible with this kernel, could someone please give me advice how to solve this situation ?
Is there a workng RPM package with foo2zjs for Red Hat 9 ?
Which files go to wich directory during the instalation ?

Options: ReplyQuote
Re: Which kernel version ?
Posted by: rickrich ()
Date: September 29, 2008 07:24AM

Redhat 7.2, 8, and 9 all supported. Before 7.2, no dice.

Options: ReplyQuote


Sorry, only registered users may post in this forum.
This forum powered by Phorum.