Samsung CLP-360, CLP-365W :  foo2zjs - foo2hp - foo2xqx - foo2lava - foo2qpdl - foo2oak
Support for linux printer drivers
The fastest message board... ever.
 
CLP-360 almost working
Posted by: pcurieux ()
Date: February 15, 2013 05:13AM

Config:
CLP-360 usb connected with sheevaplug (ARM processor) running debian 6.04
(just bougth yesterday)

driver foo2qpdl downloaded from here
compiled succesfully, installed
printer installed with cups

printing almost working, because at the bottom edge of each page a little bandwith black (or colored) is printed

don't know what is wrong?



Edited 1 time(s). Last edit at 02/15/2013 05:17AM by pcurieux.

Options: ReplyQuote
Re: CLP-360 almost working
Posted by: rickrich ()
Date: February 15, 2013 07:25AM

Read: black stripe at the bottom

Ref: black stripe at the bottom



Edited 1 time(s). Last edit at 02/15/2013 07:29AM by rickrich.

Options: ReplyQuote
Re: CLP-360 almost working
Posted by: pcurieux ()
Date: February 15, 2013 12:54PM

Thanks for this indication
(sorry I'm French and not very fluent in English)
i have read the read and ref
i tested first with 600x600 black stripe at the bottom
new test with 1200x600 =>black stripe at the bottom
with 1200*1200 all is printed twice in heigth vertically (the width is the same and ok)
but only the top half of the page is printed
and no black stripe at the bottom

don't know wath to do now

Options: ReplyQuote
Re: CLP-360 almost working
Posted by: rickrich ()
Date: February 15, 2013 03:43PM

$ system-config-printer

Under "Printer Options", change "Halftone Algorithm" to "Standard" and "Resolution" to "1200x600 dpi".

Options: ReplyQuote
Re: CLP-360 almost working
Posted by: pcurieux ()
Date: February 16, 2013 12:09AM

hello,

I made the modification with cups because the system where the printer is connected has no graphical unit.
(I verified that the ppd file was modified)
no chance the black stripe is always at the bottom

I read some doc about SPL
the black stripe looks as a band (in term of SPL) at the end of file ?
how remove it?

Options: ReplyQuote
Re: CLP-360 almost working
Posted by: rickrich ()
Date: February 16, 2013 07:28AM

What is the version of ghostscript?

Options: ReplyQuote
Re: CLP-360 almost working
Posted by: pcurieux ()
Date: February 16, 2013 08:32AM

# gs --version
8.71

it seems to be OK?

thanks for support



Edited 1 time(s). Last edit at 02/16/2013 08:34AM by pcurieux.

Options: ReplyQuote
Re: CLP-360 almost working
Posted by: rickrich ()
Date: February 16, 2013 10:40AM

Either redownload, make, make install; or apply this patch:
$ cvs diff -u foo2qpdl.c
Index: foo2qpdl.c
===================================================================
RCS file: /home/cvs/foo2zjs/foo2qpdl.c,v
retrieving revision 1.50
diff -u -r1.50 foo2qpdl.c
--- foo2qpdl.c  10 Jan 2013 19:58:51 -0000      1.50
+++ foo2qpdl.c  16 Feb 2013 15:34:11 -0000
@@ -702,6 +702,13 @@
 
     start_page_init(ofp);
 
+    switch (Model)
+    {
+    case MODEL_CLP620:
+       h -= NBAND * 2;
+       break;
+    }
+
     for (pn = 0; pn < nbie; ++pn)
     {
        stripe = 0;
$ 

Options: ReplyQuote
Re: CLP-360 almost working
Posted by: pcurieux ()
Date: February 16, 2013 11:08AM

Thanks

I have recomplied and tried
I have restarted cups before trying

the bottom edge of the page has changed
with the cups test page:
The "Printer Test Page " at the bottom disappeared leaving some kind of ink mark
(+/- the top of the highers letters ???)



Edited 1 time(s). Last edit at 02/16/2013 11:22AM by pcurieux.

Options: ReplyQuote
Re: CLP-360 almost working
Posted by: rickrich ()
Date: February 16, 2013 12:14PM

So, no black stripe at the bottom?

Fixed???

How about this (2 versus 1):
$ cvs diff -u foo2qpdl.c
Index: foo2qpdl.c
===================================================================
RCS file: /home/cvs/foo2zjs/foo2qpdl.c,v
retrieving revision 1.50
diff -u -r1.50 foo2qpdl.c
--- foo2qpdl.c  10 Jan 2013 19:58:51 -0000      1.50
+++ foo2qpdl.c  16 Feb 2013 17:32:16 -0000
@@ -702,6 +702,13 @@
 
     start_page_init(ofp);
 
+    switch (Model)
+    {
+    case MODEL_CLP620:
+       h -= NBAND * 1;
+       break;
+    }
+
     for (pn = 0; pn < nbie; ++pn)
     {
        stripe = 0;
$



Edited 1 time(s). Last edit at 02/16/2013 12:35PM by rickrich.

Options: ReplyQuote
Re: CLP-360 almost working
Posted by: pcurieux ()
Date: February 16, 2013 12:36PM

no the page is shorter than it should
at the end print is truncated
there is no more a continuous black band but some black marks
and the bottom is missing
sorry I have no picture

I will try with 1

Tried:
the bottom is a little more complete but the end is still missing and there are still some marks
below the text "Printer Test Page" as that
xXX X x X X x X x



Edited 4 time(s). Last edit at 02/16/2013 12:54PM by pcurieux.

Options: ReplyQuote
Re: CLP-360 almost working
Posted by: rickrich ()
Date: February 16, 2013 01:04PM

You know that clipping is done? Maybe your original doc was clipped as well. I am putting back the driver as it was originally.

Options: ReplyQuote
Re: CLP-360 almost working
Posted by: pcurieux ()
Date: February 16, 2013 01:18PM

Yes I know that clipping could be done
The original doc is cups test page
it was printing succesfully with other printer
printing is succesfull if I use another PC for printing like that:

CLP360 ---> sheevaplug
on sheevaplug CLP360 configured as RAW printer
connecting from a PC running Ubuntu 12.04
locally (Ubuntu) CLP360 configured with Samsung Unified driver addressing the CLP360 via network
printing works ...

so I have a workaround but I must install driver in all my PC since I cannot use the driver foo2qpdl with sheevaplug acting as a server

(the Samsung Unified driver cannot be executable upon sheevaplug because ARM architecture and Samsung driver use i386 code!!! no sources available -proprietary)

thanks I will do more tests tomorrow



Edited 3 time(s). Last edit at 02/17/2013 01:36AM by pcurieux.

Options: ReplyQuote
Re: CLP-360 almost working
Posted by: pcurieux ()
Date: February 17, 2013 06:03AM

some more tests and results

first I restore the driver to its initial state in my tests
I use few documents to test, all pdf. Tests only monochrome

I find that if I print the same doc with no options about page adjustment black stripe is there
with option reduce print to printable area, thereis no black stripe

so may be something to do with clipping?

It seems that if the document to print is naturally inside the printable area, no black stripe appears
I noted that black stripe is at the bottom edge of the paper (A4) outside of printable area

I try to modify the PPD file to reduce printing area with no effects
may be it's not sufficient or may be clipping problem?

I think that black stripe appears only when there is something to print at or outside of printable area



Edited 1 time(s). Last edit at 02/17/2013 06:05AM by pcurieux.

Options: ReplyQuote


Sorry, only registered users may post in this forum.
This forum powered by Phorum.