HP LaserJet 1020 :  foo2zjs - foo2hp - foo2xqx - foo2lava - foo2qpdl - foo2oak
Support for linux printer drivers
The fastest message board... ever.
 
El Capitan 10.11.6 does not work
Posted by: weiserguy ()
Date: July 25, 2017 04:10PM

I’ve been trying to work out why my LJ1020 stopped working recently. It appears others had the same problem, and I don't spot any solution posted, so allow me to write up my situation. Maybe it will provide some clues as to what's broken.

A couple of months back, I bought a 512 GB SSD to replace the original HDD in my 2007-vintage iMac. I created two, near-identical partitions (only the size varied by a few gigs), and cloned the bootable “Macintosh HD” partition from the HDD into *both* new partitions. One I left on OS X Mavericks, 10.9.8, the other upgraded to El Capitan 10.11.6. I had foo2zjs installed on the original HDD, and the LJ1020 worked fine.

So after doing the clones, installing the SDD and booting up into the partition with Mavericks, the LJ1020 and foo2zjs remained fully functional.

Booting up into the El Capitan partition, the printer stopped printing, similar to what others have described, i.e., you go to print something, the print driver seems to take it, the driver loads for a few seconds, and then it all disappears, but the LJ1020 never comes to life.

I can send the command line "lp -d HP_LaserJet_1020_foomatic -oraw /usr/local/share/foo2zjs/firmware/sihp1020.dl” to it, and it wakes up and hums for a moment as it initializes, but it still won't activate for a print job.

I re-downloaded and reinstalled the foo2zjs package and ghostscript, and those installs seemed to complete normally. (I did not try building the package from source code, since I never did that in the first place.) This didn’t correct the situation.

I then came across a thread in a different (hp-related) forum, and a retired hp engineer suggested downloading and installing a package of HP drivers for the Mac, and selecting the driver for the similar LJ1022 printer. I did this, which worked, and I can now print using that driver. (Though the print quality isn’t quite as sharp as what I got from foo2zjs, which really does produce perfect printouts.)

But despite a bunch of troubleshooting, looking at permissions, turning off the “rootless” feature, etc., etc., foo2zjs still won’t actually print. (Though having the 1022 driver working at least relieves the pressure.)

Do you have any suggestions? Does any of this info help to figure out what’s not working in either foo2zjs, ghostscript, zjstream or elsewhere in the package?

About the only thing that’s obvious to me is that I’m not the only person who has encountered this issue after upgrading to El Capitan (or Sierra), though I might be the only user that has parallel partitions that can demonstrate that the driver works or breaks as you boot between the two OS versions.

It’s been a long time since I did any Unix software engineering, and I’m in over my head on this problem. Any help is appreciated. Thanks.



Edited 1 time(s). Last edit at 07/25/2017 04:19PM by rickrich.

Options: ReplyQuote
Re: El Capitan 10.11.6 does not work
Posted by: rickrich ()
Date: July 25, 2017 04:20PM

From INSTALL.osx:
$ head -20 INSTALL.osx 
==============================================================================
How to Disable System Integrity Protection (rootless) in OS X El Capitan
==============================================================================

You need to disable rootless in Mac OSX 10.11 or greater.  Please follow
these instructions:

    http://osxdaily.com/2015/10/05/disable-rootless-system-integrity-protection-mac-os-x/

    $ csrutil status
    System Integrity Protection status: disabled

OR

    Doing a make install in foo2zjs directory:

        $ cd foo2zjs
        $ make install PREFIX=/usr/local

    also works.

Ref: https://github.com/jwiebalk/foo2zjs



Edited 1 time(s). Last edit at 07/25/2017 04:57PM by rickrich.

Options: ReplyQuote


Sorry, only registered users may post in this forum.
This forum powered by Phorum.