HP LaserJet 1020 :  foo2zjs - foo2hp - foo2xqx - foo2lava - foo2qpdl - foo2oak
Support for linux printer drivers
The fastest message board... ever.
 
Installation problems with Ubuntu 11.10
Posted by: CCRS8 ()
Date: October 18, 2011 08:47PM

I have successfully been using my LaserJet 1020 with Ubuntu since 7.04 with this driver (and sent a donation earlier this year as a thank you!). Anyway, after upgrading from 11.04 to 11.10, printing no longer worked. Not that big of a deal, as I'd estimate that printing breaks after about half of my Ubuntu upgrades. However, I'm having a heck of a time getting printing to work this time. I followed all the steps for installing the driver, and then added a new printer in the system-config-printer setup, but nothing I do gets the printer to fire up. Usually after turning on the printer, it will churn for a few seconds, pause, and then churn for a few more seconds while the firmware is loaded. That second step (the firmware loading) just isn't happening no matter what I do.

Any suggestions or gotchas I should know about between 11.04 and 11.10?

Options: ReplyQuote
Re: Installation problems with Ubuntu 11.10
Posted by: rickrich ()
Date: October 18, 2011 10:08PM

Did you try the latest version?

Options: ReplyQuote
Re: Installation problems with Ubuntu 11.10
Posted by: CCRS8 ()
Date: October 19, 2011 05:53AM

rickrich Wrote:
-------------------------------------------------------
> Did you try the latest version?


Yes. I deleted the existing foo2zjs.tar.gz file and foo2zjs folder from my home folder that were there from the last time I did the install and started from step one of the installation instructions ("wget -O foo2zjs.tar.gz http://foo2zjs.rkkda.com/foo2zjs.tar.gz";) to get the newest file available before continuing with the instructions.

Options: ReplyQuote
Re: Installation problems with Ubuntu 11.10
Posted by: rickrich ()
Date: October 19, 2011 07:36AM

What does this say:

$ /usr/lib/cups/backend/usb
direct usb://HP/LaserJet%201020 "HP LaserJet 1020" "HP LaserJet 1020" "MFG:Hewlett-Packard;MDL:HP LaserJet 1020;CMD:ACL;CLS:PRINTER;DES:HP LaserJet 1020;FWVER:20050309;" ""

$ usb_printerid /dev/usb/lp0
GET_DEVICE_ID string:
MFG:Hewlett-Packard;MDL:HP LaserJet 1020;CMD:ACL;CLS:PRINTER;DES:HP LaserJet 1020;FWVER:20050309;

$ DEVICE_URI=usb://HP/LaserJet%201020 /usr/lib/cups/backend/usb 1 1 1 1 '' /usr/share/foo2zjs/firmware/sihp1020.dl

Options: ReplyQuote
Re: Installation problems with Ubuntu 11.10
Posted by: CCRS8 ()
Date: October 19, 2011 10:43AM

rickrich Wrote:
-------------------------------------------------------
> What does this say:
>
> $ /usr/lib/cups/backend/usb
> direct usb://HP/LaserJet%201020 "HP LaserJet 1020"
> "HP LaserJet 1020" "MFG:Hewlett-Packard;MDL:HP
> LaserJet 1020;CMD:ACL;CLS:PRINTER;DES:HP LaserJet
> 1020;FWVER:20050309;" ""
>
> $ usb_printerid /dev/usb/lp0
> GET_DEVICE_ID string:
> MFG:Hewlett-Packard;MDL:HP LaserJet
> 1020;CMD:ACL;CLS:PRINTER;DES:HP LaserJet
> 1020;FWVER:20050309;
>
> $ DEVICE_URI=usb://HP/LaserJet%201020
> /usr/lib/cups/backend/usb 1 1 1 1 ''
> /usr/share/foo2zjs/firmware/sihp1020.dl


Thanks for the reply. I'm at work now and am going to a meeting right afterwards, so I won't be home and at my computer able to check this out again until late tonight. I didn't want you to think I had given up!

Options: ReplyQuote
Re: Installation problems with Ubuntu 11.10
Posted by: CCRS8 ()
Date: October 20, 2011 07:31AM

rickrich Wrote:
-------------------------------------------------------
> What does this say:
>
> $ /usr/lib/cups/backend/usb
> direct usb://HP/LaserJet%201020 "HP LaserJet 1020"
> "HP LaserJet 1020" "MFG:Hewlett-Packard;MDL:HP
> LaserJet 1020;CMD:ACL;CLS:PRINTER;DES:HP LaserJet
> 1020;FWVER:20050309;" ""

I got "permission denied" when I ran this as a normal user. Using sudo, I got:
DEBUG: list_devices
DEBUG: usb_find_busses=4
DEBUG: usb_find_devices=11


> $ usb_printerid /dev/usb/lp0
> GET_DEVICE_ID string:
> MFG:Hewlett-Packard;MDL:HP LaserJet
> 1020;CMD:ACL;CLS:PRINTER;DES:HP LaserJet
> 1020;FWVER:20050309;

I was able to run this command without sudo. I got:
MFG:Hewlett-Packard;MDL:HP LaserJet 1020;CMD:ACL;CLS:PRINTER;DES:HP LaserJet 1020;


> $ DEVICE_URI=usb://HP/LaserJet%201020
> /usr/lib/cups/backend/usb 1 1 1 1 ''
> /usr/share/foo2zjs/firmware/sihp1020.dl

I again had to use sudo to run this, and I got a never ending loop of this:
DEBUG: print_device
DEBUG: usb_find_busses=4
DEBUG: usb_find_devices=11
STATE: +connecting-to-device
STATE: -connecting-to-device
INFO: Waiting for printer to become available.

Options: ReplyQuote
Re: Installation problems with Ubuntu 11.10
Posted by: rickrich ()
Date: October 20, 2011 09:44AM

From the Changelog:
2011-10-20      Rick Richardson <rick.richardson@comcast.net>
        * hplj1000: Reverse the checks for Ubuntu 11.10.

Options: ReplyQuote
Re: Installation problems with Ubuntu 11.10
Posted by: CCRS8 ()
Date: October 20, 2011 11:16AM

rickrich Wrote:
-------------------------------------------------------
> From the Changelog:
>
> 2011-10-20 Rick Richardson
> * hplj1000: Reverse the checks for Ubuntu
> 11.10.
>

Great, thanks. I'll give it a try when I get home this evening. Is there anything I need to do to uninstall the old version, or should I just follow the installation instructions again from the beginning?

Options: ReplyQuote
Re: Installation problems with Ubuntu 11.10
Posted by: rickrich ()
Date: October 20, 2011 12:21PM

wget ... ; make; make install

Options: ReplyQuote
Re: Installation problems with Ubuntu 11.10
Posted by: CCRS8 ()
Date: October 20, 2011 05:27PM

I installed the new version, and things seemed to make progress but unfortunately still not printing. After installing the new version, now when the printer is turned on there are two distinct startup noises with a pause in between like there was when the printer was working in previous versions of Ubuntu (although the first noise seems a bit abbreviated from what I remember), so it looks like the firmware is loading. However, when printing a test page or a separate document, the job is sent but never prints. The printer state sits at "Processing - Waiting for printer to become available."


The output of those commands from earlier are:
$ sudo /usr/lib/cups/backend/usb
DEBUG: list_devices
DEBUG: usb_find_busses=4
DEBUG: usb_find_devices=11

$ usb_printerid /dev/usb/lp0
GET_DEVICE_ID string:
MFG:Hewlett-Packard;MDL:HP LaserJet 1020;CMD:ACL;CLS:PRINTER;DES:HP LaserJet 1020;FWVER:20050309;

$ sudo DEVICE_URI=usb://HP/LaserJet%201020 /usr/lib/cups/backend/usb 1 1 1 1 '' /usr/share/foo2zjs/firmware/sihp1020.dl
DEBUG: print_device
DEBUG: usb_find_busses=4
DEBUG: usb_find_devices=11
STATE: +connecting-to-device
STATE: -connecting-to-device
INFO: Waiting for printer to become available.

Options: ReplyQuote
Re: Installation problems with Ubuntu 11.10
Posted by: rickrich ()
Date: October 20, 2011 05:58PM

What does this say:

$ cd foo2zjs
$ foo2zjs-wrapper -P -z1 -L0 testpage.ps > xxx.prn
$ ls -l xxx.prn
-rw-rw-r-- 1 rick rick 92639 Oct 20 16:56 xxx.prn
$ cp xxx.prn /dev/usb/lp0
{printed fine}
$

Options: ReplyQuote
Re: Installation problems with Ubuntu 11.10
Posted by: CCRS8 ()
Date: October 20, 2011 06:26PM

rickrich Wrote:
-------------------------------------------------------
> What does this say:
>
> $ cd foo2zjs
> $ foo2zjs-wrapper -P -z1 -L0 testpage.ps >
> xxx.prn
> $ ls -l xxx.prn
> -rw-rw-r-- 1 rick rick 92639 Oct 20 16:56 xxx.prn
> $ cp xxx.prn /dev/usb/lp0
> {printed fine}
> $


That prints a Red Hat Printconf US Letter PostScript Test Page fine.

Options: ReplyQuote
Re: Installation problems with Ubuntu 11.10
Posted by: CCRS8 ()
Date: October 20, 2011 06:28PM

CCRS8 Wrote:
-------------------------------------------------------
> That prints a Red Hat Printconf US Letter
> PostScript Test Page fine.

Not sure if you wanted the output:
$ cd foo2zjs
$ foo2zjs-wrapper -P -z1 -L0 testpage.ps > xxx.prn
$ ls -l xxx.prn
-rw-rw-r-- 1 mgh mgh 99515 2011-10-20 18:22 xxx.prn
$ cp xxx.prn /dev/usb/lp0
{printed fine}
$

Options: ReplyQuote
Re: Installation problems with Ubuntu 11.10
Posted by: rickrich ()
Date: October 20, 2011 06:52PM

Then its a CUPS issue. URI should be:

usb:/dev/usb/lp0
or
file:/dev/usb/lp0

Options: ReplyQuote
Re: Installation problems with Ubuntu 11.10
Posted by: CCRS8 ()
Date: October 21, 2011 06:49AM

rickrich Wrote:
-------------------------------------------------------
> Then its a CUPS issue. URI should be:
>
> usb:/dev/usb/lp0
> or
> file:/dev/usb/lp0


OK - so by a CUPS issue, you mean basically a configuration issue on my part once I open up system-config-printer? I have always used usb:/dev/usb/lp0 as the URI. When I instead try file:/dev/usb/lp0, I get a CUPS server error: There was an error during the CUPS operation: 'client-error-not-possible'.

I'll keep fiddling around with these settings, I guess.

Options: ReplyQuote
Re: Installation problems with Ubuntu 11.10
Posted by: rickrich ()
Date: November 05, 2011 03:54PM

For a URI like:
     file:/dev/usb/lp0

$ cd foo2zjs
$ sudo vi /etc/cups/cupsd.conf
<insert this line>
FileDevice Yes
$ make cups

Options: ReplyQuote


Sorry, only registered users may post in this forum.
This forum powered by Phorum.