"connecting to printer" RPi, HP P1102
Posted by: napoleone ()
Date: December 10, 2013 04:29PM


I've connected my printer P1102 to the Raspberry Pi, using CUPS.
Pi sees the printer, Windows 7 sees and adds the printer as well. It is on, but doesn't print...

The driver is from the PPD folder. CUPS, Raspberry Pi and Windows see it online, but it doesn't respond to print. I have no idea why. Please, help.

Edited 1 time(s). Last edit at 12/10/2013 04:31PM by napoleone.

Re: "connecting to printer" RPi, HP P1102
Posted by: rickrich ()
Date: December 10, 2013 04:52PM

What does this say:
$ cd foo2zjs

$ foo2zjs-wrapper -P -z2 -L0 testpage.ps > xxx

$ ls -l xxx
-rw-rw-r-- 1 rick rick 92675 May 10 08:21 xxx

$ sudo cp xxx /dev/usb/lp0
...printed OK...

Also see: http://foo2zjs.rkkda.com/forum/read.php?43,3658

Edited 1 time(s). Last edit at 12/10/2013 04:55PM by rickrich.

Re: "connecting to printer" RPi, HP P1102
Posted by: e1000i ()
Date: June 12, 2014 05:15AM


I know this thread is quate old, but having the same problem make sense to ask here. Do any one make theyr printer work with the Pi?

I have installed the usb-modeswitch and following your indications rickrich i can print the test page. This is running cp xxx /dev/usb/lp0 prints the page. But i don't know how to add it to cups.

The webinterface only show:
HP LaserJet Professional P1102 USB 000000000Q80HKRJPR1a HPLIP (HP LaserJet Professional P1102)
HP LaserJet Professional P1102 (HP LaserJet Professional P1102)

I selected first the middle one, as says nothing about hplip. Anyway when selecting the drivers it give me two options:
HP Laserjet Professional P1102 hpijs, 3.12.6, requires proprietary plugin (en)
HP Laserjet Professional P1102 hpcups, 3.12.6, requires proprietary plugin (en)

All warns me about the need of a privative plugin, that i alredy now don't exist for arm based machines. So which option is the one usable. I tested both options that i'm not able to print any test page there...

I also tried to add the printer manually with:
lpadmin -p piprinter -v "/dev/usb/lp0" -E -P /usr/share/cups/model/HP-LaserJet_Pro_P1102.ppd.gz

But not works either. Any clue on what to try next?

Re: "connecting to printer" RPi, HP P1102
Posted by: rickrich ()
Date: June 13, 2014 07:59AM

Device URI: usb://HP/LaserJet%20Professional%20P1102
Make and Model: HP LaserJet Pro P1102 Foomatic/foo2zjs-z2 (recommended)

Note: "HP Laserjet Professional" uses the proprietary drivers from HP. "HP LaserJet Pro" uses my drivers.

Re: "connecting to printer" RPi, HP P1102
Posted by: Raspi_developer ()
Date: September 13, 2014 02:22PM

Hello all,

I am trying to get print with HP LaserJet P1102 using CUPS. all commands rickrich asked to execute seem working ok. I followed "HP SMART INSTALL NOTES" suggested here http://foo2zjs.rkkda.com/INSTALL but i never got the printout anyway. I also tried using USB Powered Hub but no printout. Please suggest me what i should do to get the printer running. I am using Raspberry Pi Model B+ with Raspbian.


Re: "connecting to printer" RPi, HP P1102
Posted by: Raspi_developer ()
Date: September 18, 2014 11:23AM

Hello all,
I finally got printer working with raspberry Pi

sudo apt-get update
sudo apt-get install hplip
apt-get install cups
wget -O foo2zjs.tar.gz http://foo2zjs.rkkda.com/foo2zjs.tar.gz
tar zxf foo2zjs.tar.gz
cd foo2zjs
make install
make cups
adduser pi lpadmin

i dint find foo2zjs with HPLJ P1102 rather found with HPLJ 1020 just added this and continued with default page setup and it worked perfect.

Still i am confused why foo2zjs isn't appearing with HP LJ P1102.

Thanks to people helped me.
Good luck.

Sorry, only registered users may post in this forum.
This forum powered by Phorum.