top half of the first line is not printed [solved]
Posted by: RodoB ()
Date: December 07, 2010 09:46AM

I'm using Ubuntu 9.04 with GPL Ghostscript 8.64. I installed latest foo2zjs (dic 3 2010) and installed the hp 1102w printer wirelessly.

The problem I'm having is when I send a text file, about the top half of the first line is not printed. Any idea what can I check or change?

I tried option -u xoffxyoff but it only makes things worse (I would need a negative offset?).

Any hints? I'd like to help fix this for other users who might need it too. Thanks.

Edited 2 time(s). Last edit at 12/22/2010 09:38AM by rickrich.

Re: top half of the first line is not printed
Posted by: rickrich ()
Date: December 07, 2010 10:21AM

From the Changelog:
2010-05-07      Rick Richardson <>
        * Modify: foo2zjs.c: if Model == MODEL_HP_PRO, blank initial lines
            for 0.25".  Sheesh!!!
Works as expected.

Edited 1 time(s). Last edit at 12/07/2010 10:22AM by rickrich.

Re: top half of the first line is not printed [solved]
Posted by: SnowRaptor ()
Date: February 10, 2011 05:40PM

I'm not sure if this completely solves the issue.

When I send a CUPS Printer test page, like this one

With default settings I get the page about a centimeter displaced down and half centimeter borders without print, thus, the top ruler is missing up to the top 1;4 of the numerals, the side rulers are missing the smaller scale ticks almost entirely and the bottom ruler bleeds outside of the page, with the bottom border of the paper almost at the numerals' baseline.

I couldn't find an obvious way to correct this via CUPS.

I'm using A4 paper, CUPS 1.3.11 and GhostScript 864.

The "Imageable area" reads:

Page size 210,0x297,0mm
Lower-left 0,0x0,0mm
Upper-right 210,0x297,0mm
Resolution 1200x600dpi

A similar problem of displacement and "cutting" happens with CUPS 1.4.5 and ghostscript 8.71, but this time the printable area goes from 4x4mm to 206x293mm

Sorry, only registered users may post in this forum.
This forum powered by Phorum.