Duplexer, too [solved]
Posted by: DerPpit ()
Date: June 15, 2010 05:55AM


We just got a new printer, a Samsung CLP-620ND. Running it in an Linux-only environment, with an openSUSE 11.2 (ghostscript upgraded to 8.70) and your foo2qpdl as print server.

While things are fine (thanks!), the 620 has the same trouble as has been reported for the 610 in http://foo2zjs.rkkda.com/forum/read.php?55,1432

The automatic duplexer is not working. It only prints one side on the first sheet (although it is pulling the paper into the duplexer unit), then complains that the MP tray is empty. If I insert paper in the MP tray, it will print the second page. (Both the printer itself and the printing options specify tray 1 (only) as paper source)...

Are the respective fixes for the 610 also in the ppd for the 620? If not, could they be taken over 1:1? My problem is that I cannot supply a windows print to file, as I don't have a windows machine here.....



Edited 1 time(s). Last edit at 04/13/2011 07:03AM by rickrich.

Re: Duplexer, too
Posted by: DerPpit ()
Date: June 15, 2010 08:49AM

Uh, I have to follow-up myself. So far I had only tried 2-page documents. In the meantime I had a try with a 6-page one, and there things get even more weird:

- It starts with duplex-printing, but prints the odd pages, i.e., 1-3-5
1 and 3 are on one sheet (front and back), 5 on another (empty back)

- Then it complains that MP tray is empty and stops

- When I open the MP tray and insert some paper it continues, printing pages 6-4-2 (i.e., in reversed order), again 6 and 4 on one sheet, 2 on a single one. In addition, those pages are top-down...

Edited 1 time(s). Last edit at 06/15/2010 08:51AM by DerPpit.

Re: Duplexer, too
Posted by: DerPpit ()
Date: June 15, 2010 11:01AM

More news:

It seems to be a collision between the preprocessor and the settings of the printer (?). I have set the printer to default to duplex mode, both on the printer itself and in the CUPS configuration.

However, if I now print with -o Duplex=None, it just 'does the right thing' and prints double-sided with correct page numbering....

Still a bit puzzled by this....

Re: Duplexer, too
Posted by: rickrich ()
Date: June 15, 2010 11:03AM

From the Changelog:
2010-06-15      Rick Richardson <rick.richardson@comcast.net>
        * foo2qpld foomatic-db and PPD files: fix Duplex for clp-6100, clp-610,
          clp-620. Manual Duplex is no longer supported. Use Gnome-Manual-Duplex

          Please delete and recreate the Samsung CLP-6?? printers.

Please wget, make, etc. and delete and recreate your CLP-620.

Re: Duplexer, too
Posted by: DerPpit ()
Date: June 17, 2010 10:04AM

Thanks a lot! Works like a charm now.

Sorry, only registered users may post in this forum.
This forum powered by Phorum.