Samsung CLP-310, CLP-315 :  foo2zjs - foo2hp - foo2xqx - foo2lava - foo2qpdl - foo2oak
Support for linux printer drivers
The fastest message board... ever.
 
CLP-315W autoconf produces solid red light, no printing with Ubuntu 9.10
Posted by: iiridayn ()
Date: December 13, 2009 03:23AM

Output of sudo usb_printerid /dev/usb/lp0:
GET_DEVICE_ID string:
MFG:Samsung;CMD:SPLC;MDL:CLP-310 Series;CLS:PRINTER;STATUS:BUSY;

Helping a new user transition to Ubuntu linux, but after following the Ubuntu-specific instructions correctly from the INSTALL file, I have a new autodetecting printer, but it is always busy. That above is the output immediately following the installation process. I get
Error: Device or resource busy: can't open '/dev/usb/lp0'
once I attempt to run any commands.

Previously I had some success by following the steps at http://foo2qpdl.rkkda.com/fedora/clp315.html to add another copy of the printer (currently printer is not showing up after a wipe and reinstall), but it broke and would not work again (solid red light issue, system-config-printer throwing client-error-document-format-not-supported when attempting to print a printer test page, etc).

I'd like to do this correctly this time so that I don't have to try to fix it again - any advice as to what I might do better to make it work permanently? Last time it broke by said user printing out a 30 page color document, realizing that said user did not want said document (or to spend the toner for it), and removed power to the printer as the most expeditious way to prevent it. Upon restoring power, the printer failed to run.

Note - in light of what I had working before, I will reinstall by instructions again from scratch, but this time not make install-hotplug, and create a printer per the url stated above. Very good documentation in the INSTALL file, also - almost could have asked the user to do it and they would have done as well a job.

Options: ReplyQuote
Re: CLP-315W autoconf produces solid red light, no printing with Ubuntu 9.10
Posted by: iiridayn ()
Date: December 13, 2009 03:54AM

Did not work, but light now orange after plugging into a windows machine and back into Ubuntu, spat out this error page:
SPL-C ERROR - Incomplete Session by time out
POSITION: 0xeb49
SYSTEM: src/os_hook
LINE: 1646
VERSION: SPL-C 5.35 11-20-2007

I'll check it out, but I need to go to sleep - now 2 am here.

Options: ReplyQuote
Re: CLP-315W autoconf produces solid red light, no printing with Ubuntu 9.10
Posted by: rickrich ()
Date: December 13, 2009 11:27AM

Works good on Ubuntu 9.10 with all updates applied.
$ dmesg
...snip...
[11860.848245] usb 1-1: new high speed USB device using ehci_hcd and address 3
[11861.071350] usb 1-1: configuration #1 chosen from 1 choice
[11861.109665] usblp0: USB Bidirectional printer dev 3 if 0 alt 0 proto 2 vid 0x04E8 pid 0x328E
[11862.291162] usb 1-1: usbfs: interface 0 claimed by usblp while 'usb' sets config #1


Options: ReplyQuote


Sorry, only registered users may post in this forum.
This forum powered by Phorum.