HP2600N connecting to EEEPC
Posted by: davidaustin2006 ()
Date: April 02, 2008 08:12AM

Hi All,
I should state at the outset that I know next to nothing about Linux, so please forgive my simplistic detail of my problem.

Basically, I am trying to use a HP2600N as a printer for my EEEPC which is running the "plain vanilla" user interface. Reading various postings,I believe the Operating system is a modified version of Xandros.

The scenario I have is a D-Link DSL-G604T Wireless Router/Modem that is connected to my ADSL server. The Router has 4 wired inputs, plus wireless connectivity. I am currently using 3 of the 4 inputs (1 PC running Windows XP, 1 PC running Windows Vista & an HP2600N colour laser printer). They are all networked together so that either PC can print to the HP2600N (providing the router is switched on of course!!).

I recently bought the EEEPC, and have successfully set it up to connect wirelessly to the router, and can thus access the Internet, and exchange files between it and the other 2 PCs. So far so good!!

I would like to be able to print from the EEEPC to the HP2600N, so I went to the "Add Printer" wizard on the EEEPC. I select "Network Printer", and "Network type as "Other". I select "AppSocket/HP JetDirect (socket)" and "Find". This takes me to the "Find Network Printer" with a Subnet of 10.1.1.* 9100. I hit "Scan" and it finds the printer at 10.1.1.4 (The base address of the Router is 10.1.1.1). I select this and hit "Next", and it takes me to the "Set Printer Model" page where it has already selected Manufacturer as "HP" Model as "Color Laser Jet 2600N" and Driver as "Foomatic + foo2hp" so I click "Next", and it opens a new page and asks if I want to send a Test Page. I select "Yes", and it appears to send some data, as its status goes from "Idle, Accepting Jobs" to "Busy, Accepting Jobs" and shortly thereafter back to "Idle Accepting Jobs". Unfortunately, nothing happens at the printer.

I have tried different drivers, but nothing seems to work. If I select "foomatic + foo2zjs", I get the printer to start up, and eject paper, but nothing is printed on it. I tried also sending small documents, but again no joy.

I have seen descriptions for installing foo2hp, but none of them seems to relate to the EEEPC environment, so I am reluctant to try in case I mess up the system. Also I don't know if it is the same "foo2hp" I already have pre-installed on the EEEPC, so I may be wasting my time trying to download it.

Assuming it is a updated version, how do I install it? Does it replace the existing one or is it stored in another location. Also the driver says "foomatic + foo2hp", so does "foomatic" also get downloaded at the same time as the "foo2hp" if I use the one on this website? You can see, I am really struggling here, so I would welcome any advice.

I have contacted HP & ASUS, and they all "disavow any knowledge of my actions"!!
I have searched every HP, Linux & EEEPC forum, but come up empty.

Incidentally, I also connected the HP2600N direct into one of the USB ports on the EEEPC. It was recognised and installed with the same drivers, but with precisely the same result ie NOTHING, so it is not a network problem, but seemingly a driver problem. Needless to say, the 2 PCs on the network can print flawlessly to the HP2600N, so it is not a fault on the printer. Also, if I type in from the EEEPC web browser "http://10.1.1.4"; it brings up the Printer's Webpage, so the network seems to be working fine.

Any thoughts.
All advice gladly accepted, and naturally a donation would be forthcoming if I can solve this problem.
Regards
davidaustin2006

Re: HP2600N connecting to EEEPC
Posted by: rickrich ()
Date: April 02, 2008 09:22AM

Follow my instructions on the EEE PC...

Don't forget it needs "gcc" et al. installed FIRST.

Do:

http://wiki.eeeuser.com/howto:installingdevelopmenttools

Then:
        $ wget -O foo2zjs.tar.gz http://foo2zjs.rkkda.com/foo2zjs.tar.gz
        $ tar zxf foo2zjs.tar.gz
        $ cd foo2zjs
        $ sudo make uninstall
        $ make
        $ ./getweb 2600n
        $ sudo make install cups
        $ firefox http://localhost:631


Re: HP2600N connecting to EEEPC
Posted by: davidaustin2006 ()
Date: April 02, 2008 09:53AM

Hi rickrich,
Thanks for your comprehensive reply to my rambling post.

I'm not sure what exactly "gcc" is but I will follow the instructions.

I cannot quite understand the part :-

"log out of your superuser bash by ^D or exit; then cd /tmp; create a file hello.c with the obvious content, then gcc hello.c; ./a.out
Alternately you may want to go for these:

http://update.eeepc.asus.com/p701/pool/gcc-4.1-base_4.1.1-21_i386.deb
http://update.eeepc.asus.com/p701/pool/cpp-4.1_4.1.1-21_i386.deb
http://update.eeepc.asus.com/p701/pool/libc6-dev_2.3.6.ds1-13_i386.deb";

How do you create a file called "hello.c", and what is the "obvious content"? I'm afraid it is not that obvious to a mere "linux newbie". Also are the 3 files you mention to be downloaded, as the alternative to creating this "hello.c" file.
Sorry to be so stupid, but I don't want to mess up my system by keying in the wrong command.

Thanks again for your assistance.
davidaustin2006

Re: HP2600N connecting to EEEPC
Posted by: rickrich ()
Date: April 02, 2008 10:34AM

$ cat >hello.c
#include <stdio.h>

int main(void) {
    printf("Hello, world!\n");
}
$ gcc hello.c
$ ./a.out
Hello, world!
$

Re: HP2600N connecting to EEEPC
Posted by: davidaustin2006 ()
Date: April 02, 2008 09:24PM

Hi,
Thanks for the clarification re. creating the "hello.c" file.

I'm still not sure of the relevance of the last 3 urls relating to p701.
Are they alternatives to doing steps 1 to 8?

What is the significance of the "firefox" step

Assming I am successful installing "gcc" and "foo2zjs", how do I proceed to install the drivers? Do I still use the "Add Printer Wizard" and use the same "foomatic + foo2hp" drivers or do I select another driver?

Thanks in advance
davidaustin2006

Re: HP2600N connecting to EEEPC
Posted by: davidaustin2006 ()
Date: April 03, 2008 07:04AM

Hi,
Just an update om where I'm at.

I first tried to install "gcc" as suggested.

I got to Terminal mode (CTRL-Alt-T) and then typed "sudo su" which took me to the root directory.

I found a ftp mirror site in Australia (ftp.netspace.net.au/pub/debian).

I typed in "sudo kwrite /etc/apt/sources.list" which opened up "sources.list" and added the extra line
"deb ftp://ftp.netspace.net.au/pub/debian stable main contrib non-free"
and saved the file (File then Save).

The typed in "get-apt update"

It appeared to try to connect to asus update, but after a while "Timed out", so I guess no updates were loaded.

I then tried typing in "apt-get install build-essential", but it kept saying it didn't understand the command, so at this point I abandoned the quest.

Any ideas what I am doing wrong?

BTW I tried creating the file "hello.c" following the instructions, but don't think it actually generated any file, and then typing the "gcc' instruction was ignored.

How do you actually save the file created?

Any advice appreciated.
Regards
davidaustin2006

Re: HP2600N connecting to EEEPC
Posted by: davidaustin2006 ()
Date: April 03, 2008 09:04AM

Hi,
A further update to my problem.

I remembered that I had difficulty getting "add/remove programs" to work, and i had searched through the forums to find a solution. The solution is described below :-

"I have found a workaround! It will also get synaptic to work, for those who want to install the advanced desktop, which I was able to do successfully using the Wiki instructions. This workaround is mentioned elsewhere in the forums.

1) Open Firefox and type the following: "http://update.eeepc.asus.com/p701";. Firefox will display the directory structure of update files.
2) Open a new tab and type the following: "http://download.tuxfamily.org/eeepcrepos/dists/";. Firefox will display this directory structure.
3) Add/Remove Programs will now run correctly. So will synaptic.

I don't know the root cause for this, but I believe the problem is getting the Eee to correctly resolve the update URLs to their IP addresses."

I tried opening Firefox, and entering these two URLs, and then tried the "apt-get update" again. Sure enough it started downloading and installing updates, but it failed on the last one, which was the one I added onto the sources.list. I tried the .au one and the .nl one but no luck. Similarly trying the "apt-get install" failed. That's as far as I can get.
Regards
davidaustin2006

Re: HP2600N connecting to EEEPC
Posted by: rickrich ()
Date: April 03, 2008 09:27AM

Please do stuff about

http://wiki.eeeuser.com/howto:installingdevelopmenttools

on their Wiki, not mine!

Re: HP2600N connecting to EEEPC
Posted by: davidaustin2006 ()
Date: April 08, 2008 01:17AM

Hi All,

Many thanks for all the help I received.

I have had a bit of a success today. For the benefit of those who come after I will detail how I got there.

1. As I mentioned before, I could not download the "foo2zjs.tar.gz" directly from my EEEPC. I therefore downloaded it onto one of my PCs (the one running XP Home). I put it on the "Desktop", and then transferred it onto a "USB Thumb-drive".

2. I plugged the Thumb-drive into the EEEPC and used "File Manager" under the "Work" tab to transfer it onto the EEEPC.

3. I went into Terminal mode (Ctrl-Alt-T) and typed in "tar zxf foo2zjs.tar.gz"

4. I checked with "File Manager" and it looks as if a new folder called (I think) "foo2zjs" was created with heaps of files in it .

5. I tried to compile by typing in "cd foo2zjs" which changed directory to "foo2zjs" but the command "make" was rejected. I tried several times and used "sudo make" but every time rejected.

6. I looked through the files on this new directory with "File Manager" and found a sub-folder called "PPD". On opening this I found quite a few files including "hp2600n.ppd"

7. I went to the "Settings" tab and then "Printers" and "Add". Selected "Network" and "Other". I used "Find" to detect the Printer at "10.1.1.4" (my Router starts at 10.1.1.1). I selected this and "OK".

8. The next page asked to select the Printer & Driver, I selected HP2600N, but then clicked on "Got PPD".

9. I browsed to the PPD directory and selected hp2600n.ppd and opened it. then selected "next" .
It asked if I wanted to print a Test Page and selected "Yes", and amazingly it printed a Test Page.

10. I tried printing a document, and that was OK, and then inserted a colour picture on the document, but it printed in "Monochrome". I went to the "Printer settings" and selected "Colour", and this time it printed in colour, but the colours a bit "washed out", but at least I can print colour, and documents to the HP2600N which is all I wanted to do.

Thanks again to all, and I will make a contribution to the development fund.

davidaustin2006

Re: HP2600N connecting to EEEPC
Posted by: davidaustin2006 ()
Date: April 08, 2008 04:35AM

Hi,
Just as a postscript to what I posted earlier, I think one can skip a couple of steps, but I'm not game to try now the printer is working.

When I downloaded the foo2zjs.tar.gz file to the desktop of my PC running Windows XP Home, it asked if I wanted to extract files using Winzip. Just for the heck of it I tried this (not expecting it to work), but it did actually extract all the files. It occurred to me that, I probably only needed to have the hp2600n.ppd file on the EEEPC to get the Printer working. So instead of taking the whole of foozjs.tar.gz across to the EEEPC (either by a USB Thumbdrive, or via the Network using "File Manager"),and extracting it locally in the EEEPC, I could probably just copied across the .ppd file (by Thumb-drive or File Manager), and then installed the printer as I explained before.

I will not bother to check whether this will work, but maybe some-one also struggling to install the HP2600N would care to try.

Best of Luck

davidaustin2006

Re: HP2600N connecting to EEEPC
Posted by: rickrich ()
Date: April 08, 2008 09:05AM

No, thats not correct. You need the whole thing on your EEE PC:
eeepc$ sudo apt-get install wget
eeepc$ make
eeepc$ ./getweb 2600n
eeepc$ sudo make install
Also, ghostscript is 8.15.
gs-esp         8.15.3.dfsg.1- The Ghostscript PostScript interpreter - ESP
You should read the INSTALL file:
BUGS
----
    * Well Tempered Screening (WTS) works with ghostscript 8.54-8.62+.
      So if you want BEST COLORS, you'll have to install gs 8.54 or
      better if you don't have it.

        $ gs --version
        8.15.2

        $ wget "http://mirror.cs.wisc.edu/pub/mirrors/ghost/GPL/gs862/ghostscript-8.62.tar.gz";
        $ tar zxf ghostscript-8.62.tar.gz
        $ cd ghostscript-8.62
        $ ./autogen.sh
        $ make
        $ su                            OR $ sudo cp bin/gs /usr/bin/gs.foo
        # cp bin/gs /usr/bin/gs.foo

        (Optional)
        # make install                  OR $ sudo make install

        $ gs.foo --version
        8.62


Sorry, only registered users may post in this forum.
This forum powered by Phorum.