Nothing prints out [gs is buggy, RedHat EL]
Posted by: jtoc ()
Date: March 02, 2008 10:31PM

I've had no problems printing to my 2600n since I set up a year ago until suddenly today. I followed the procedure above-- it didn't print, and I got back an error message:

[root@localhost foo2zjs]# ./foo2hp2600-wrapper testpage.ps >xxx
Not a pbm file!

I haven't made any changes to my system, installed any software, or really done anything. Any advice?

Thanks.
-M



Edited 3 time(s). Last edit at 03/03/2008 04:19PM by rickrich.

Re: Nothing prints out
Posted by: rickrich ()
Date: March 02, 2008 10:54PM

Works here on Fedora 8 (32bit and 64bit)...
$ ./foo2hp2600-wrapper testpage.ps >xxx 
$ ll xxx
-rw-rw-r-- 1 rick rick 62432 2008-03-02 21:49 xxx
What distro???

Re: Nothing prints out
Posted by: jtoc ()
Date: March 03, 2008 03:42PM

Distro is Scientific Linux 3.0.8, which is essentially Redhat Enterprise.

Re: Nothing prints out
Posted by: rickrich ()
Date: March 03, 2008 04:01PM

Did you do make, make install, etc.?

Re: Nothing prints out [gs is buggy, RedHat EL]
Posted by: jtoc ()
Date: March 03, 2008 06:39PM

Yes. I did that when I originally installed and it worked fine. I re-made and re-make-installed it just now and got no error messages, but it still didn't fix the problem. I'm still getting the same "Not a PBM File!" error message when I try the foo2hp command above.

Re: Nothing prints out [gs is buggy, RedHat EL]
Posted by: rickrich ()
Date: March 03, 2008 07:09PM

Its ghostscript. Try (from INSTALL):
BUGS
----
    * Well Tempered Screening (WTS) works with ghostscript 8.54-8.61+.
      So if you want BEST COLORS, you'll have to install gs 8.54 or
      better if you don't have it.

        $ gs --version
        8.15.2

        $ wget "http://mirror.cs.wisc.edu/pub/mirrors/ghost/GPL/gs861/ghostscript-8.61.tar.gz";
        $ tar zxf ghostscript-8.61.tar.gz
        $ cd ghostscript-8.61
        $ ./autogen.sh
        $ make
        $ su                            OR $ sudo cp bin/gs /usr/bin/gs.foo
        # cp bin/gs /usr/bin/gs.foo
        $ gs.foo --version
        8.61

Re: Nothing prints out [gs is buggy, RedHat EL]
Posted by: jtoc ()
Date: March 04, 2008 09:27AM

Still no luck. Installed the new GS, and, for good measure, reinstalled foo2hp. No change in the situation. Got this:

[root@localhost foo2zjs]# ./foo2hp2600-wrapper testpage.ps >xxx
Not a pbm file!
/usr/bin/foo2zjs-pstops: line 92: 18395 Broken pipe sed -e "$w" -e "$n" $@

Re: Nothing prints out [gs is buggy, RedHat EL]
Posted by: rickrich ()
Date: March 04, 2008 10:02AM

It is ghostscript. Sorry. Don't know what I can do.

Re: Nothing prints out [gs is buggy, RedHat EL]
Posted by: jtoc ()
Date: March 04, 2008 12:34PM

Thank you for the help. I appreciate you taking the time.

I think it's strange that printing using foo2hp worked for months and then suddenly stopped. I still don't know what caused it to stop working. Strange.

Re: Nothing prints out [gs is buggy, RedHat EL]
Posted by: jtoc ()
Date: March 06, 2008 10:13AM

I managed to fix it. I deleted all the print queues, reinstalled foo2hp, got ghostscript 8.62 and did a make install with it, and then finished the foo2hp setup. Thanks for your help.

Sorry, only registered users may post in this forum.
This forum powered by Phorum.