HP LaserJet P1006 / P1008 :  foo2zjs - foo2hp - foo2xqx - foo2lava - foo2qpdl - foo2oak
Support for linux printer drivers
The fastest message board... ever.
lpr print command fails (solved)
Posted by: skyhawk ()
Date: November 24, 2014 02:10PM

For my HP LaserJet P1006, foo2xqx prints pages when I do the following:

$ foo2xqx-wrapper output.ps > /dev/usb/lp0

It does not print when I do the following, as user or root:

# lpr -P HP_LaserJet_P1006 output.ps

Additional information is given by the following commands:

# usb_printerid /dev/usb/lp0
MFG:Hewlett-Packard;MDL:HP LaserJet P1006;CMD:HBS,PJL,ACL;CLS:PRINTER;DES:HP LaserJet P1006;FWVER:20090916;

# lpstat -p -d
printer HP_LaserJet_P1006 is idle. enabled since Sun 23 Nov 2014 04:36:35 PM UTC
no system default destination

# lpoptions -d HP_LaserJet_P1006
auth-info-required=none copies=1 device-uri=usb:/dev/usb/lp0 finishings=3 job-hold-until=no-hold job-priority=50 job-sheets=none,none marker-change-time=0 number-up=1 printer-commands=AutoConfigure,Clean,PrintSelfTestPage printer-info='monochrome laser printer' printer-is-accepting-jobs=true printer-is-shared=false printer-location=desktop printer-make-and-model='HP LaserJet P1006 Foomatic/foo2xqx (recommended)' printer-state=4 printer-state-change-time=1416853232 printer-state-reasons=connecting-to-device printer-type=10522644 printer-uri-supported=ipp://localhost:631/printers/HP_LaserJet_P1006

Any ideas why the lpr print command is not working? Foo2xqx is installed on Slitaz 4.0. The CUPS (v1.4.6) interface was used to add and manage the printer.

Edited 1 time(s). Last edit at 12/06/2014 03:03PM by skyhawk.

Options: ReplyQuote
Re: lpr print command fails
Posted by: rickrich ()
Date: November 24, 2014 04:03PM

Power down, then power up the printer? No idea really.

Options: ReplyQuote
Re: lpr print command fails
Posted by: skyhawk ()
Date: November 25, 2014 02:55PM

Thanks for your reply, Rick. I'll try to find a solution for this little problem, and I'll post if I find an answer.

I want to add that I'm very impressed with the amount of effort that has gone into developing your printer drivers. Many, many manhours, I would guess. As a matter of fact, I plan to join that elite group of users who have sent a donation. My thanks for doing what, most of the time, probably seems like a thankless job.

Options: ReplyQuote
Re: lpr print command fails (solved)
Posted by: skyhawk ()
Date: December 06, 2014 02:58PM

Success. "lp/lpr" print commands now functional. Added hal-cups-utils package from Slitaz repository. Also, lsusb package, which only serves to fetch info from usb ports. I think hal-cups-utils.tazpkg was the essential, missing component. The distro documentation is very sketchy on printers, so I had to solve this puzzle myself.

Now can print simply by using:

lp any.ps

Foo2xqx is a big improvement over hplip-3.12.2.tazpkg with its unresolvable dependencies, most of which are not necessary for my print-only HP LaserJet P1006.

I will send a donation first thing next week.

Edited 1 time(s). Last edit at 12/06/2014 03:04PM by skyhawk.

Options: ReplyQuote

Sorry, only registered users may post in this forum.
This forum powered by Phorum.