HP LaserJet P1006 / P1008 :  foo2zjs - foo2hp - foo2xqx - foo2lava - foo2qpdl - foo2oak
Support for linux printer drivers
The fastest message board... ever.
 
virtualbox + driver foo2xqx + HP LaserJet P1006
Posted by: gti9001splus ()
Date: April 25, 2012 03:46AM

I have problem.
Lubuntu 12.04 in virtualbox 4.1.10 r76836, host is windows xp sp3. Printer HP LaserJet P1006, with driver foo2xqx.

Sometimes the printer doesn't print. tasks go to queue and appear there with the status - is executed.
Here the log of the press of test page through debugging http://pastebin.com/xEpxy9XM.
Noticed if to disconnect the printer from virtualbox, to print in windows, it starts to print in linux.

Options: ReplyQuote
Re: virtualbox + driver foo2xqx + HP LaserJet P1006
Posted by: rickrich ()
Date: April 25, 2012 07:01AM

It is a CUPS problem.

Options: ReplyQuote
Re: virtualbox + driver foo2xqx + HP LaserJet P1006
Posted by: gti9001splus ()
Date: May 24, 2012 02:46AM

usb_printerid /dev/usb/lp0
GET_DEVICE_ID string:
MFG:Hewlett-Packard;MDL:HP LaserJet P1006;CMD:ACL;CLS:PRINTER;DES:HP LaserJet P1006;

There is firmware?
/usr/share/foo2xqx/firmware/sihpP1006.dl present

syslog http://pastebin.com/EBgfgxBH
cups error_log http://pastebin.com/aJrPgZxm
cups access_log http://pastebin.com/2gg7SCnb
cups page_log http://pastebin.com/hGMg7Bp7

Options: ReplyQuote
Re: virtualbox + driver foo2xqx + HP LaserJet P1006
Posted by: gti9001splus ()
Date: May 24, 2012 06:50AM

Firmware don't load then printer plug or power on.

This load firmware,
cat /usr/share/foo2xqx/firmware/sihpP1006.dl > /dev/usb/lp0

How to fix loading firmware when device is connected?

Options: ReplyQuote
Re: virtualbox + driver foo2xqx + HP LaserJet P1006
Posted by: rickrich ()
Date: May 24, 2012 07:34AM

# sudo make install-hotplug

Options: ReplyQuote
Re: virtualbox + driver foo2xqx + HP LaserJet P1006
Posted by: gti9001splus ()
Date: May 25, 2012 12:46AM

remove system-config-printer-udev

then

sudo make install-hotplug
#
# Hotplug Installation Dependencies...
#
# ... OK!
#
#
# remove HPLIP (proprietary) files and install our version
#
if [ -d /etc/udev/rules.d ]; then \
rm -f /etc/udev/rules.d/*hpmud*laserjet_1000*; \
rm -f /etc/udev/rules.d/*hpmud*laserjet_1005*; \
rm -f /etc/udev/rules.d/*hpmud*laserjet_1018*; \
rm -f /etc/udev/rules.d/*hpmud*laserjet_1020*; \
rm -f /etc/udev/rules.d/*hpmud*laserjet_p1005*; \
rm -f /etc/udev/rules.d/*hpmud*laserjet_p1006*; \
rm -f /etc/udev/rules.d/*hpmud*laserjet_p1007*; \
rm -f /etc/udev/rules.d/*hpmud*laserjet_p1008*; \
rm -f /etc/udev/rules.d/*hpmud*laserjet_p1505*; \
rm -f /etc/udev/rules.d/*hpmud_support.rules; \
rm -f /lib/udev/rules.d/*-hplj10xx.rules; \
version=`/sbin/udevd --version 2>/dev/null`; \
if [ "$version" = "" ]; then version=0; fi; \
echo "*** udev version $version"; \
if [ "$version" -lt 148 ]; then \
install -c -m 644 hplj10xx.rules.old /etc/udev/rules.d/11-hplj10xx.rules; \
else \
install -c -m 644 hplj10xx.rules /etc/udev/rules.d/11-hplj10xx.rules; \
fi \
fi
*** udev version 175
if [ -d /etc/devd ]; then \
install -c -m 644 hplj10xx.conf /etc/devd/; \
fi
[ -d /etc/hotplug/usb ] || install -d -m 755 /etc/hotplug/usb/
install -c -m 755 hplj1000 /etc/hotplug/usb/
ln -sf /etc/hotplug/usb/hplj1000 /etc/hotplug/usb/hplj1005
ln -sf /etc/hotplug/usb/hplj1000 /etc/hotplug/usb/hplj1018
ln -sf /etc/hotplug/usb/hplj1000 /etc/hotplug/usb/hplj1020
ln -sf /etc/hotplug/usb/hplj1000 /etc/hotplug/usb/hpljP1005
ln -sf /etc/hotplug/usb/hplj1000 /etc/hotplug/usb/hpljP1006
ln -sf /etc/hotplug/usb/hplj1000 /etc/hotplug/usb/hpljP1007
ln -sf /etc/hotplug/usb/hplj1000 /etc/hotplug/usb/hpljP1008
ln -sf /etc/hotplug/usb/hplj1000 /etc/hotplug/usb/hpljP1505
/etc/hotplug/usb/hplj1000 install-usermap
/etc/hotplug/usb/hplj1005 install-usermap
/etc/hotplug/usb/hplj1018 install-usermap
/etc/hotplug/usb/hplj1020 install-usermap
/etc/hotplug/usb/hpljP1005 install-usermap
/etc/hotplug/usb/hpljP1006 install-usermap
/etc/hotplug/usb/hpljP1007 install-usermap
/etc/hotplug/usb/hpljP1008 install-usermap
/etc/hotplug/usb/hpljP1505 install-usermap
# modprobe usblp
/etc/hotplug/usb/hplj1000 install-usblp

now in dmesg

[ 176.078825] usb 1-1: USB disconnect, device number 2
[ 186.745481] usb 1-1: new high-speed USB device number 3 using ehci_hcd
[ 187.528320] usblp0: USB Bidirectional printer dev 3 if 0 alt 0 proto 2 vid 0x03F0 pid 0x3E17
[ 187.790679] usblp0: nonzero write bulk status received: -108
[ 187.800423] usblp0: removed
[ 198.806464] usblp: can't set desired altsetting 0 on interface 0

Options: ReplyQuote


Sorry, only registered users may post in this forum.
This forum powered by Phorum.