HP LaserJet P1006 / P1008 :  foo2zjs - foo2hp - foo2xqx - foo2lava - foo2qpdl - foo2oak
Support for linux printer drivers
The fastest message board... ever.
 
P1006+Mint (Debian) no print [solved. Firmware is NOT loaded]
Posted by: picothinker ()
Date: May 13, 2010 02:32AM

I tried to follow the instructions, as well as the ones in INSTALL.

# uname -a
Linux comfort-desktop 2.6.31-14-generic #48-Ubuntu SMP Fri Oct 16 14:04:26 UTC 2009 i686 GNU/Linux

I did all of this:

$ su
# apt-get install build-essential tix foomatic-filters groff cupsys dc

$ wget -O foo2zjs.tar.gz http://foo2zjs.rkkda.com/foo2zjs.tar.gz
$ tar zxf foo2zjs.tar.gz
$ cd foo2zjs
$ make
$ ./getweb P1006
$ su
# make install install-hotplug cups
Unplug and re-plug the USB printer
$ firefox http://localhost:631

Create printers (Debian)
Connect with a web browser to:
http://localhost:631
And configure printer (HP example shown) to:
HP LaserJet 2600n, Foomatic + foo2zjs (en)

I do not have a choice for foo2zjs, only foo2xqx

usb_printerid /dev/usb/lp0
GET_DEVICE_ID string:
MFG:Hewlett-Packard;MDL:HP LaserJet P1006;CMD:ACL;CLS:PRINTER;DES:HP LaserJet P1006;

# lpq
Hewlett-Packard-HP-LaserJet-P1006 is ready
no entries

At very first I was getting "no firmware" in var/log/messages, now there are no complaints, but it doesn't seem to be working.

thx-Scott




Edited 2 time(s). Last edit at 05/13/2010 10:14AM by rickrich.

Options: ReplyQuote
Re: P1006+Mint (Debian) Firmware loads, no print
Posted by: rickrich ()
Date: May 13, 2010 04:45AM

Firmware is not getting loaded:

GET_DEVICE_ID string:
MFG:Hewlett-Packard;MDL:HP LaserJet P1006;CMD:ACL;CLS:PRINTER;DES:HP LaserJet P1006;

Should be:

GET_DEVICE_ID string:
MFG:Hewlett-Packard;MDL:HP LaserJet P1006;CMD:ACL;CLS:PRINTER;DES:HP LaserJet P1006; FWVER=NNNNNNNN;

See: "HP LASERJET 1000/1005/1018/1020, P1005/P1006/P1007/P1008/P1505 NOTES"
in INSTALL file.

Options: ReplyQuote
Re: P1006+Mint (Debian) no print [Firmware is NOT loaded]
Posted by: picothinker ()
Date: May 13, 2010 09:42AM

Thanks for the response, Rick. As per the HP P1006 notes, I did run make install-hotplug (had to apt-get remove a udev printer thing that was present, no problem. When I first started trying this, letting tail -f /var/log/messages run in a terminal, the act of plugging in the USB gave me messages of "MIssing Firmware". At the point of sending the post last night, it was no longer saying that, but no orange light.

I had locally heavy storms last night, I powered everything down, and MUCH TO MY SURPRISE just simply powering it up this morning, I saw the orange light for the first time, it seems to work (as far as a test page goes). I don't consider rebooting to be a valid step in Linux.

Will my mis-matched GET_DEVICE_ID string be a problem in the future?

thx-Scott

Options: ReplyQuote
Re: P1006+Mint (Debian) no print [Firmware is NOT loaded]
Posted by: rickrich ()
Date: May 13, 2010 10:13AM

$ pwd
/home/rick/proj/foo2zjs

$ grep "Missing Firmware" *
$

Not from foo2zjs!

$ usb_printerid /dev/usb/lp0

What does that say?

Options: ReplyQuote


Sorry, only registered users may post in this forum.
This forum powered by Phorum.