HP LaserJet P1006 / P1008 :  foo2zjs - foo2hp - foo2xqx - foo2lava - foo2qpdl - foo2oak
Support for linux printer drivers
The fastest message board... ever.
 
hp p1006 on debian[version?] [solved. Firmware is not loaded]
Posted by: roberto ()
Date: January 31, 2010 07:12AM

hello, i read a past topic on hp p1006 on debian since i get the same problem:
- CUPS tells me the printer is correctly installed using foo2xqx
- i try to print the test page but nothing happens

which is the directory where to issue 'make' and the rest of commands ?

this is the output of:
$ sudo usb_printerid /dev/usb/lp0
GET_DEVICE_ID string:
MFG:Hewlett-Packard;MDL:HP LaserJet P1006;CMD:ACL;CLS:PRINTER;DES:HP LaserJet P1006;


thank you



Edited 3 time(s). Last edit at 02/03/2010 03:30PM by rickrich.

Options: ReplyQuote
Re: hp p1006 on debian
Posted by: rickrich ()
Date: January 31, 2010 07:38AM

Firmware is not downloaded. See "CUPS USB NOTES" and "HP LASERJET 1000/1005/1018/1020, P1005/P1006/P1007/P1008/P1505 NOTES" in the INSTALL file, which you did read, right???

$ cd foo2zjs
$ make
$ ./getweb P1006                      #IMPORTANT!!!
$ sudo make install install-hotplug   #IMPORTANT!!!
Power down and up the printer.

$ sudo usb_printerid /dev/usb/lp0
What does that say???



Edited 2 time(s). Last edit at 01/31/2010 07:54AM by rickrich.

Options: ReplyQuote
Re: hp p1006 on debian
Posted by: roberto ()
Date: February 03, 2010 02:58PM

rickrich Wrote:
-------------------------------------------------------
> Firmware is not downloaded. See "CUPS USB NOTES"
> and "HP LASERJET 1000/1005/1018/1020,
> P1005/P1006/P1007/P1008/P1505 NOTES" in the
> INSTALL file, which you did read, right???
sure, since this is the second time i install a printer to my laptop

>
>
> $ cd foo2zjs
> $ make
done
> $ ./getweb P1006
my fault ! i did it now

> #IMPORTANT!!!
> $ sudo make install install-hotplug
done

> #IMPORTANT!!!
> Power down and up the printer.
>
> $ sudo usb_printerid /dev/usb/lp0
>
> What does that say???
here it is:
$ sudo usb_printerid /dev/usb/lp0
GET_DEVICE_ID string:
MFG:Hewlett-Packard;MDL:HP LaserJet P1006;CMD:HBS,PJL,ACL;CLS:PRINTER;DES:HP LaserJet P1006;FWVER:20080415;

the test page is printed correctly now, so i assume everything works fine

thanks again !

Options: ReplyQuote


Sorry, only registered users may post in this forum.
This forum powered by Phorum.