HP LaserJet P1005 / P1007 :  foo2zjs - foo2hp - foo2xqx - foo2lava - foo2qpdl - foo2oak
Support for linux printer drivers
The fastest message board... ever.
 
HP laserjet P1007 on linux mint 7
Posted by: manoj57 ()
Date: March 11, 2010 10:23AM

i use linux mint 7 on dell lattitude D830. i have tried several times to install driver. i used foo2xqx from foo2zjs. many times i have been able to take print but it was soon after installation. once computer is switched OFF, then ON it was not working. the error message was 'printer may not be connect' actually the printer was connected. once it was failure of foomatic.rip
after all this i want to know
what should be the URI
if i have firmware on local machine than what command should be used instead of $./getweb P1007.
sihpP1005.tar.gz: Permission denied
getweb: Couldn't download http://foo2zjs.rkkda.com/firmware/sihpP1005.tar.gz
Why the permission is denied, i have downloaded sihpP1005.tar.gz through firefox and extracted it to sihpP1005.img in /home/manoj/foo2xqx. can it be used instead of downloading it everytime.
which plug in should be used.
incidently i was able to install it on my ACER Travelmate2410 and it working with URI as usb://HP/LaserJet%20P1007 and driver as foomatic/foo2xqx
pl help



Edited 1 time(s). Last edit at 03/12/2010 01:32PM by manoj57.

Options: ReplyQuote
Re: HP laserjet P1007 on linux mint 7
Posted by: rickrich ()
Date: March 13, 2010 04:45PM

$ rm -rf foo2zjs

$ wget -O foo2zjs.tar.gz http://foo2zjs.rkkda.com/foo2zjs.tar.gz

$ tar zxf foo2zjs.tar.gz
$ cd foo2zjs

$ make 
...

$ ./getweb P1007
sihpP1005.img

(c) Copyright Hewlett-Packard 2008

$ sudo make install install-hotplug
...

Options: ReplyQuote
Re: HP laserjet P1007 on linux mint 7
Posted by: manoj57 ()
Date: March 14, 2010 01:37PM

i have tried it but it has not worked.
i have two laptop, Dell and Acer and on Acer it is working. i tried to figure out the difference. i could find one. on Acer, when HPLaserJetP1007 is plugged in, in /dev folder /dev/usb folder and in usb folder /dev/usb/lp0 file is created and in Dell too the /dev/usb folder and /dev/usb/lp0 file are created but they are short lived they disappear within few second. and i believe there lies the problem. help



Edited 1 time(s). Last edit at 03/22/2010 11:16AM by manoj57.

Options: ReplyQuote


Sorry, only registered users may post in this forum.
This forum powered by Phorum.