HP LaserJet P1005 / P1007 :  foo2zjs - foo2hp - foo2xqx - foo2lava - foo2qpdl - foo2oak
Support for linux printer drivers
The fastest message board... ever.
 
New CUPS (1.4.1) and usblp [Gentoo not supported]
Posted by: ZogG ()
Date: November 11, 2009 01:30PM

As i understood i need usblp for firmware autoupdate, but new CUPS doesn't detect printer with usblp turned on in kernel, so i have it turned off. So do i need to ignore thist detection and turn usblp and printer would be autoadded anyway/ should i downgrade CUPS/ should i keep usblp turned off and find anotherway(for manual firmware update)



Edited 1 time(s). Last edit at 11/12/2009 04:24PM by rickrich.

Options: ReplyQuote
Re: New CUPS (1.4.1) and usblp
Posted by: rickrich ()
Date: November 11, 2009 02:10PM

Always use usblp!!!! I am running cups 1.4.1 and don't have an issue!

See: /http://foo2xqx.rkkda.com/fedora/p1005.html
$ rpm -q cups
cups-1.4.1-4.fc11.i586

$ lsmod | grep usblp
usblp                  10884  0 

$ ll /dev/usb
total 0
crw-rw----  1 root root 180, 96 2009-11-06 16:29 hiddev0
crw-rw----  1 root root 180, 97 2009-11-06 16:29 hiddev1
crw-rw-rw-+ 1 root lp   180,  0 2009-11-06 16:29 lp0
$
From the INSTALL file:
CUPS USB NOTES
--------------
    If you are using the USB port, then the URI should be:
        usb:/dev/usb/lp0
        usb:/dev/usb/lp1
    OR
        usb://Samsung/CLP-310%20Series
        usb://Samsung/CLP-310%20Series
        usb://HP/Color%20LaserJet%20CP1215
        usb://HP/Color%20LaserJet%202600n
        usb://HP/LaserJet%201000
        usb://HP/LaserJet%201005
        usb://HP/LaserJet%201018
        usb://HP/LaserJet%201020
        usb://HP/LaserJet%20P1005
        usb://HP/LaserJet%20P1006
        usb://HP/LaserJet%20P1505

    Don't use hp://<whatever> because that is for hplip (a closed source,
    proprietary driver).



Edited 1 time(s). Last edit at 11/11/2009 04:00PM by rickrich.

Options: ReplyQuote
Re: New CUPS (1.4.1) and usblp
Posted by: ZogG ()
Date: November 12, 2009 04:10PM

I can't use usblp, when it's on - CUPS doesn't find printer. I turned it off and it did, but after i has installed printer and turn on/off printer (for frimware) usblp modules turns on back, but... if i send print it does nothing till i turn module off.(it's known problem of cups btw in many distors, i'm on gentoo)
btw i succeded to print(when i turn usblp off) but 600/600 dpi doesn't print properly not normal not draft (just it's like wvery very draft that u can't see anything) and 1200/600 dpi prints good. but don't see any difference between draft and normal. any ideas?
and i installed foo2zjs from source while deleting all hplip(not working at all for me) and foo2zjs from portage but still have 3 same foo2xqx drivers in the list and has noone "recommended" as you on screenies on the link above. thanx for help =)

Options: ReplyQuote
Re: New CUPS (1.4.1) and usblp
Posted by: rickrich ()
Date: November 12, 2009 04:23PM

Only 1200x600 (the default) works on p1005.

Get Fedora or other SUPPORTED distro...

Options: ReplyQuote
Re: New CUPS (1.4.1) and usblp [Gentoo not supported]
Posted by: ZogG ()
Date: November 12, 2009 04:54PM

haha, it's not an option. It's CUPS changes, but not distros, so it's not gentoo bug, i think in fedora tey use some hack (it's possible in gentoo, playing around with --disble-libusb while compiling CUPS)
and what about draft - is it supported for p1005?

Options: ReplyQuote
Re: New CUPS (1.4.1) and usblp [Gentoo not supported]
Posted by: rickrich ()
Date: November 12, 2009 05:14PM

From Changelog:
2009-11-12      Rick Richardson <rick.richardson@comcast.net>
        * foo2xqx.c: set PJL ECONOMODE ON/OFF



$ ./foo2xqx-wrapper  testpage.ps | xqxdecode | grep ECON
@PJL SET ECONOMODE=OFF
        XQXI_ECONOMODE, 0 (0x0)

$ ./foo2xqx-wrapper -t testpage.ps | xqxdecode | grep ECON
@PJL SET ECONOMODE=ON
        XQXI_ECONOMODE, 1 (0x1)

Options: ReplyQuote
Re: New CUPS (1.4.1) and usblp [Gentoo not supported]
Posted by: ZogG ()
Date: November 12, 2009 05:45PM

huh, just added it? is it managable with cups or wrapper only ( cause i don't really know how to use it)

Options: ReplyQuote
Re: New CUPS (1.4.1) and usblp [Gentoo not supported]
Posted by: ZogG ()
Date: November 12, 2009 11:42PM

tryed to set draft for default in cups and gnome-cups-manager, but in return always have
# foo2xqx-wrapper testpage.ps | xqxdecode | grep ECON
@PJL SET ECONOMODE=OFF
XQXI_ECONOMODE, 0 (0x0)

Options: ReplyQuote
Re: New CUPS (1.4.1) and usblp [Gentoo not supported]
Posted by: rickrich ()
Date: November 13, 2009 03:51AM

gnome-cups-manager DOES NOT work!!! It is full of BUGS. Use system-config-printer instead.

From the PPD file for P1005:
*OpenUI *Quality/Printing Quality: PickOne
*FoomaticRIPOption Quality: enum CmdLine A
*OrderDependency: 110 AnySetup *Quality
*DefaultQuality: normal
*Quality draft/Draft: "%% FoomaticRIPOptionSetting: Quality=draft"
*FoomaticRIPOptionSetting Quality=draft: " -t  "
*Quality normal/Normal: "%% FoomaticRIPOptionSetting: Quality=normal"
*FoomaticRIPOptionSetting Quality=normal: "  "
*CloseUI: *Quality

Options: ReplyQuote


Sorry, only registered users may post in this forum.
This forum powered by Phorum.