Xerox Phaser 6115MFP :  foo2zjs - foo2hp - foo2xqx - foo2lava - foo2qpdl - foo2oak
Support for linux printer drivers
The fastest message board... ever.
 
Xerox Phaser 6115MFP XML file fault
Posted by: ophers ()
Date: May 11, 2015 05:34AM

Hello,
First thanks for a great projects.
I've downloaded the latest release and installed it.
I found that in the source the file:
foo2zjs/foomatic-db/printer/Xerox-Phaser_6115MFP.xml
erroneously contains:
<driver>foo2qpdl</driver>
instead of:
<driver>foo2lava</driver>

This also results in this command giving an error:
$ /usr/lib/cups/driver/foomatic -p Xerox-Phaser_6115MFP

ERROR: foomatic: Printer 'Xerox-Phaser_6115MFP' and driver 'foo2qpdl' are not compatible
The printer (null) (null) (ID: Xerox-Phaser_6115MFP) is not supported by the driver foo2qpdl!
Could not run "foomatic-combo-xml"/"foomatic-perl-data"! at /usr/lib/perl5/vendor_perl/5.8.8/Foomatic/DB.pm line 572.

Thanks.

Options: ReplyQuote
Re: Xerox Phaser 6115MFP XML file fault
Posted by: rickrich ()
Date: May 11, 2015 06:34PM

Thanks. Integrated.

$ head ChangeLog
2015-05-11 Rick Richardson <rick.richardson@comcast.net>
* Bug in foomatic-db/printer/Xerox-Phaser_6115MFP.xml . Should use
foo2lava driver. Thanks to user "ophers".

Options: ReplyQuote


Sorry, only registered users may post in this forum.
This forum powered by Phorum.