Xerox Phaser 6110 :  foo2zjs - foo2hp - foo2xqx - foo2lava - foo2qpdl - foo2oak
Support for linux printer drivers
The fastest message board... ever.
 
Problem w/6110N on openSUSE 11.2 x86_64 [solved; use ghostscript 8.70]
Posted by: flips ()
Date: February 20, 2010 11:00AM

Had problems getting the printer to work after I installed the x86_64 version, found that the Xerox driver had empty x86_64 directories. After some Googling I found this project, f002zjs. Looks promising.

I followed the instructions on the main page: http://foo2qpdl.rkkda.com/
Downloaded, unpacked, ./getweb 6110, make, make install, yast2 printer
(JetDirect/Sockett 9100, IP address, A4)
No errors.
But the print job is just stuck.

I read the message on Ghostscript 8.64 being broken with color prints. My ghostscript version might have this problem:
I have ghostscript-library-8.64-6.2.1.x86_64 from the 11.2-updates repo
But I get the same problem with B/W printing.
If you think it's essential, I could try compiling a newer ghostscript. (I suspect dependencies will break if I try installing older RPM(s).)

I get this
Quote

I [20/Feb/2010:14:35:51 +0100] [Job 10] Queued on "Spock" by "root".
I [20/Feb/2010:14:35:51 +0100] [Job 10] Started filter /usr/lib64/cups/filter/texttops (PID 28753)
I [20/Feb/2010:14:35:51 +0100] [Job 10] Started filter /usr/lib64/cups/filter/pstops (PID 28754)
I [20/Feb/2010:14:35:51 +0100] [Job 10] Started filter /usr/lib64/cups/filter/foomatic-rip (PID 28755)
I [20/Feb/2010:14:35:51 +0100] [Job 10] Started backend /usr/lib64/cups/backend/socket (PID 28756)
E [20/Feb/2010:14:39:00 +0100] [Job 10] recoverable: Unable to connect to printer; will retry in 30 seconds...

nmap shows that the printer has the jetdirect port available (I think):
9100/tcp filtered jetdirect

I did do "Test Connection" in the YAST Printer utility while adding the printer, and it reported the connection to be OK.
I tried using regular LPD instead. The Connection Test in YAST reported "Test OK", but I still get somewhat similar log output, or at least similar delay/timeout (cups error_log).

Not sure where to go/what to try next ...
I did get the printer working using SpliX, but then just 600x600 dpi.

The weird thing, is that I have to power off/on the printer everytime I try to print using the foo2zjs driver. The printer stops responding ... (This might be the reason LPD failed.)

There is no crisis, as I got printing working, but it would be interesting to figure out what the problem is, and maybe I could get full dpi and stuff working. That would be nice. :)

I hope I have provided enough info for this to be informative.
--
flips 8)



Edited 1 time(s). Last edit at 02/20/2010 03:55PM by rickrich.

Options: ReplyQuote
Re: Problem w/6110N on openSUSE 11.2 x86_64
Posted by: rickrich ()
Date: February 20, 2010 11:46AM

$ cd foo2js
$ foo2qpdl-wrapper -n2 testpage.ps > xxx.prn

$ ls -l xxx.prn
-rw-rw-r-- 1 rick rick 92188 2010-02-20 10:43 xxx.prn

$ nc 192.168.X.Y 9100 < xxx.prn
[printed OK on Fedora 11]
$

What does that say???

Options: ReplyQuote
Re: Problem w/6110N on openSUSE 11.2 x86_64
Posted by: flips ()
Date: February 20, 2010 03:15PM

Yay, got it working. (Before I read your post, so I didn't get to try that debugging.)

Quote
/var/log/cups/error_log
I [20/Feb/2010:21:02:42 +0100] [Job 19] Completed successfully.
I [20/Feb/2010:21:02:47 +0100] Started "/usr/lib64/cups/cgi-bin/printers.cgi" (pid=12186)

It seems that some part of the ghostscript software was the problem all along.

I downloaded the latest ghostscript-library source package from openSUSE factory, and then
Quote
bash
$ rpmbuild --rebuild ghostscript-library-8.70-15.3.src.rpm
$ cd /usr/src/packages/RPMS/x86_64/ && sudo rpm -Fvh ghostscript*.rpm libgimpprint*

Now it's working, and I found the DPI under driver options, so I have 1200x1200 and beautiful colors.

Thanks guys for making this software/driver and thank God that I got it working. :)

--
flips 8-)

Options: ReplyQuote


Sorry, only registered users may post in this forum.
This forum powered by Phorum.