Samsung CLP-300 :  foo2zjs - foo2hp - foo2xqx - foo2lava - foo2qpdl - foo2oak
Support for linux printer drivers
The fastest message board... ever.
 
Error when installing [Puppy linux ]
Posted by: hushpuppy ()
Date: July 03, 2007 04:16AM

I am trying to install this driver onto a Puppy Linux system.

Cups is installed, a networked HP5 works fine.

When trying to "make install" i get "invalid user 'lp', from reading another post on the puppy forum i changed lp to lpr in the makefile, still no success.

I realise that useradd lp will cure this problem, but suspect i musnt be installing as lp, but as some other user, can anyone suggest what to try ?



Edited 1 time(s). Last edit at 07/26/2007 04:51AM by rickrich.

Options: ReplyQuote
Re: Error when installing
Posted by: rickrich ()
Date: July 03, 2007 08:05AM

useradd lp

Options: ReplyQuote
Re: Error when installing
Posted by: hushpuppy ()
Date: July 03, 2007 12:34PM

The problem was that Puppy linux doesnt have any users, and a limited version of groupadd.

The solution was to edit the makefile, and change the user from lp to root.

[edited by rickrich]



Edited 1 time(s). Last edit at 07/03/2007 03:10PM by rickrich.

Options: ReplyQuote
Re: Error when installing
Posted by: hushpuppy ()
Date: July 03, 2007 12:35PM

Should have added, printer driver now works under Puppy.

Options: ReplyQuote


Sorry, only registered users may post in this forum.
This forum powered by Phorum.