Samsung CLP-300 :  foo2zjs - foo2hp - foo2xqx - foo2lava - foo2qpdl - foo2oak
Support for linux printer drivers
The fastest message board... ever.
 
CLP-300 gamma
Posted by: jhansonxi ()
Date: February 22, 2017 01:15AM

foo2zjs.c,v 1.109 2011/11/12 16:39:53
Xubuntu 16.04 (Xenial) amd64

Color prints from my CLP-300 are way too dark, as if the gamma is set too low. Changing it in the printer settings (system-config-printer v1.5.7) has no effect.

Tried with Gimp (including gimp-gutenprint with PPD) and Krita.

Tried with custom PPD and ICM from:
https://ubuntuforums.org/showthread.php?t=879902

Tried repo printer-driver-foo2zjs (20151024dfsg0-1ubunut1) and compiled version from:
http://foo2zjs.rkkda.com/foo2zjs.tar.gz

CUPS shows:
Driver: Samsung CLP-300 Foomatic/foo2qpdl (recommended) (color, 2-sided printing)

This problem has existed for several years and I was able to mitigate it in the past on Ubuntu 12.04 or so but can't find a solution now.

Options: ReplyQuote
Re: CLP-300 gamma
Posted by: jhansonxi ()
Date: February 23, 2017 02:48AM

I compiled ghostscript 8.71 and tried again. I encountered some problems.

The package link listed in INSTALL is broken since the devs moved to git. I couldn't find the earlier version from them so I used the Ubuntu source tarball.

Needed the config and make parameters:
./autogen.sh --without-jbig2dec
make -j4 CFLAGS+="-DHAVE_SYS_TIME_H=1"

However, it failed to compile due to a problem with tiff:
gcc  -DHAVE_MKSTEMP -DHAVE_HYPOT -DHAVE_FILE64 -DHAVE_MKSTEMP64 -DHAVE_FONTCONFIG -DHAVE_SYS_TIME_H=1 -I./obj -I./base  -Itiff/libtiff -I./obj  -Izlib -o ./obj/gdevtfax.o -c ./base/gdevtfax.c
In file included from tiff/libtiff/tiffio.h:33:0,
                 from ./base/gdevtifs.h:22,
                 from ./base/gdevtfax.c:16:
tiff/libtiff/tiff.h:100:2: error: unknown type name ‘uint32’
  uint32 tiff_diroff; /* byte offset to first directory */
  ^
tiff/libtiff/tiff.h:119:2: error: unknown type name ‘uint32’
  uint32  tdir_count; /* number of items; length in spec */
  ^
tiff/libtiff/tiff.h:120:2: error: unknown type name ‘uint32’
  uint32  tdir_offset; /* byte offset to field data */
  ^
In file included from ./base/gdevtifs.h:22:0,
                 from ./base/gdevtfax.c:16:
tiff/libtiff/tiffio.h:61:9: error: unknown type name ‘uint32’
 typedef uint32 ttag_t;          /* directory tag */
         ^
tiff/libtiff/tiffio.h:64:9: error: unknown type name ‘uint32’
 typedef uint32 tstrile_t;       /* strip or tile number */
…

Workaround was to configure Tiff separately then try again:
cd tiff
./configure
cd ..
make -j4 CFLAGS+="-DHAVE_SYS_TIME_H=1"
sudo make install

which gs
/usr/local/bin/gs

gs --version
8.71

Unfortunately no change with the output.

Options: ReplyQuote


Sorry, only registered users may post in this forum.
This forum powered by Phorum.