Samsung CLP-300 :  foo2zjs - foo2hp - foo2xqx - foo2lava - foo2qpdl - foo2oak
Support for linux printer drivers
The fastest message board... ever.
 
clp-300 unable to set duplex, not using gnome [solved; use gnome-manual-duplex]
Posted by: blas ()
Date: May 07, 2011 06:34AM

Hi,
I have read the topic about gnome manual duplex, but I don't want to use a 3rd party application for duplexing, when I had the option for it in the kde print dialog (when printing a pdf from okular for example). Now that option is greyed out. In system-config-printer there is an option "sides" but when I change it to double sided, and hit apply it reverts back to single. My question is why the duplex option is greyed out in recent kde? I tested it in kubuntu 10.10, 11.04 and recent mandriva/mageia, and the regression can be found in all of them (all on kde 4.6). On Mandriva 2010.1 everything was working perfectly. Has something changed in your driver or is it a kde print system error? Just to know where to file a bug report.
Thank you!



Edited 1 time(s). Last edit at 05/07/2011 06:58AM by rickrich.

Options: ReplyQuote
Re: clp-300 unable to set duplex, not using gnome
Posted by: rickrich ()
Date: May 07, 2011 06:57AM

gnome-manual-duplex was written by me.

MANUAL DUPLEX
-------------

    See:
        https://sourceforge.net/projects/g-manual-duplex/

        Install:
            $ make
            $ su
            # make install      -OR-    $ sudo make install

        Then using the GUI:
            1)  System -> Gnome Manual Duplex
                -OR-
            2)  Add to Panel -> Gnome Manual Duplex applet -> Add
                    ...Do it at least once, then...
                Print -> GnomeManualDuplex (Virtual Printer) -> Print
            Works with *.ps and *.pdf files.

        - Print odd pages
        - Wait for confimation message
        - Insert in the same orientation into the printer
        - Print reverse even pages

        Howto (video):
            http://www.youtube.com/watch?v=c4Ghomz6RQI

    -OR-
        $ psmandup [options] file.ps

        Ref:
            Fedora: # yum install a2ps
            Ubuntu: $ sudo apt-get install a2ps

    -OR-
        Print -> Page Setup -> Only print -> Odd Sheets

        then:

        Print -> Page Setup -> Only print -> Even Sheets

    -OR-
        Print -> Job -> Odd Pages

        then:

        Print -> Job -> Even Pages

    Ref:
        http://bugzilla.gnome.org/show_bug.cgi?id=520598

Options: ReplyQuote
Re: clp-300 unable to set duplex, not using gnome [solved; use gnome-manual-duplex]
Posted by: blas ()
Date: May 07, 2011 08:51AM

Thank you for the fast reply!
From the reference bug report http://bugzilla.gnome.org/show_bug.cgi?id=520598 it seems that you wrote the program because there was no option in evince for manual duplex. In kde-land this option was there in the print dialog gui of okular (the kde equivalent of evince) and it was working perfectly with your clp-300 driver. I just wanted to know what is the cause of the regression.
Until it is fixed your program seems to be a good alternative, thank you for making it. But in the long run I feel it an unnecessary extra step if duplex printing was already working with kde before.

Options: ReplyQuote
Re: clp-300 unable to set duplex, not using gnome [solved; use gnome-manual-duplex]
Posted by: rickrich ()
Date: May 07, 2011 09:42AM

Okular -> Print -> Copies -> Page Set -> Odd Pages

Okular -> Print -> Copies -> Page Set -> Even Pages

Or, get somebody to write a "KDE Manual Duplex" utility.

Options: ReplyQuote


Sorry, you can't reply to this topic. It has been closed.
This forum powered by Phorum.