Samsung CLP-300 :  foo2zjs - foo2hp - foo2xqx - foo2lava - foo2qpdl - foo2oak
Support for linux printer drivers
The fastest message board... ever.
 
CLP-300 No More Duplex [solved; use Gnome Manual Duplex]
Posted by: Madeye ()
Date: November 12, 2010 08:01AM

Hi,

I've been using the foo2qpdl driver for some time with my CLP-300 and have been very happy with it.

I've just recently tried to install it on 2 more machines - which worked fine (so fine it was worth stumping up some cash for).

The 2 machine now print fine, however the "Duplex" option has disappeared from the options page. While the CLP-300 does not support proper duplex, it does support a mode where you reinsert the pages and hit the go button.

My original installation supports this just fine and it is a feature I use extensively. This option seems to be missing on the new installs. Is this a feature that has been removed or is it just that I have installed/configured the driver wrong?

Many thanks for any help that can be offered



Edited 1 time(s). Last edit at 11/12/2010 08:39AM by rickrich.

Options: ReplyQuote
Re: CLP-300 No More Duplex
Posted by: rickrich ()
Date: November 12, 2010 08:38AM

MANUAL DUPLEX
-------------

    See:
        https://sourceforge.net/projects/g-manual-duplex/

        Install:
            $ make
            $ su
            # make install      -OR-    $ sudo make install

        Then using the GUI:
            1)  System -> Gnome Manual Duplex
                -OR-
            2)  Add to Panel -> Gnome Manual Duplex applet -> Add
                    ...Do it at least once, then...
                Print -> GnomeManualDuplex (Virtual Printer) -> Print
            Works with *.ps and *.pdf files.

        - Print odd pages
        - Wait for confimation message
        - Insert in the same orientation into the printer
        - Print reverse even pages

        Howto (video):
            http://www.youtube.com/watch?v=c4Ghomz6RQI

    -OR-
        $ psmandup [options] file.ps
        
        Ref:
            Fedora: # yum install a2ps
            Ubuntu: $ sudo apt-get install a2ps

    -OR-
        Print -> Page Setup -> Only print -> Odd Sheets

        then:

        Print -> Page Setup -> Only print -> Even Sheets

    -OR-
        Print -> Job -> Odd Pages

        then:

        Print -> Job -> Even Pages 

    Ref:
        http://bugzilla.gnome.org/show_bug.cgi?id=520598



Edited 1 time(s). Last edit at 01/25/2011 05:33PM by rickrich.

Options: ReplyQuote
Re: CLP-300 No More Duplex
Posted by: Tybion ()
Date: January 25, 2011 05:08PM

Thanks, Rick. That's great - I also have a CLP-300, and have been trying to resolve this problem since upgrading to Maverick Ubuntu.

CUPS-PDF seems to be a nice adjunct to Gnome Manual Duplex (although I have only done very little testing at this stage) ..

  Install CUPS-PDF (a package if you use Ubuntu)

  Create a new printer on your PC:

      System -> Administration -> Printing -> Add

      Choose 'Generic CUPS-PDF Printer' for the device

      Accept default description of 'Generic-CUPS-PDF-Printer'

  Print all your duplex documents using this virtual printer - it will create a PDF file in a 'PDF' folder in your home directory.

  Now, from a computer preferably near the printer, use Gnome Manual Duplex to send the .pdf file to your printer.

Options: ReplyQuote
Re: CLP-300 No More Duplex
Posted by: rickrich ()
Date: January 25, 2011 05:33PM


Options: ReplyQuote


Sorry, only registered users may post in this forum.
This forum powered by Phorum.