Minolta-QMS magicolor 2200 DL :  foo2zjs - foo2hp - foo2xqx - foo2lava - foo2qpdl - foo2oak
Support for linux printer drivers
The fastest message board... ever.
Using 2200DL with OS X (May apply to Linux too)
Posted by: jake4130 ()
Date: February 12, 2009 10:50PM

Hoping my headaches help someone else avoid them.

So the other day I got inspired. Figured I would give the foo2zjs software another shot with the Minolta 2200DL color laser. Figured I would just start from scratch and install everything again in case I missed something. I tried this about a year ago and just about lost my mind and had to put it away.

Now I don't know if it made any difference, but I have this Printer on my network and it is already working fine on a Windows PC. Might have something to do with why this worked. Not sure.

Putting the project aside for a while has served me well. In that time someone has put together OS X installer packages for all three required packages so no more compiling the code and make and install and resolving dependencies, etc. The link to those packages:


Pretty straight forward. Only thing that was a little strange is one of the installers completes and runs a script to open a terminal session to install the specific printer driver. Makes sense. An installer just needs admin privileges. Installing the driver evidently requires root privileges. So it dumps you into the terminal and runs a sudo command to install it and gives you a list. (Packages are from a reputable linux site so no worries there) Everything installed without a hitch.

Now getting the printer added to the available printers on the computer. Not so fun. The tutorial where I found the installer packages assumed you are using a parallel to USB adapter. Given that scenario it should be auto detected. I'm not using that though, I have it on the network. So I found familiar tutorial that I was looking at when I was messing with this way back when and was following it. Obviously I have the IP set up on the printer and that is working fine through the router. Windows prints to it just fine after all.

No luck. No matter what I did it couldn't connect. Would add the printer just fine but wouldn't print. The info seemed legit. It even noted some specifics. Said to add it as a HP DirectJet and and that my particular printer used port 35. Most printers spool on 9100.

Missed the part that specified that you have to use the CUPS (Common Unix Print System) interface to add it as you cant specify a port number other than the default 9100 through the standard Mac Printer Utility. No worries. Open a web browser and go to localhost:631. CUPs pulls up and I add the printer with the proper port as specified. Still no go.

By this time I'm just trying different combos of settings to see if I can get it to work. Socket://, IPP://, different port numbers I have seen, etc. Nothing and I'm getting pretty fatigued. At this point I am sending test prints but expecting nothing to come out and really not paying any attention. Pretty much ready to give up.

Figure maybe I have something goofed on the G4 as this is the machine I was working with before. I was doing the compile, make, make install method then. So I install the software on the MacBook that hasn't been messed with. Same results, same issues.

I pull the printer properties on the Windows side and notice something. The properties say its on port 515. I try that. No dice. So I'm ready to say f#$% it.

I take one more deep look and comparison of the properties on the windows side. The printer is noted as an IPR printer, not HP Appsocket/DirectJet. I remember seeing that option in CUPS so I figure its worth a try. I choose LPD/LPR. I add in

. CUPS doesn't like it. Wont even add it with IPR. So I try

. it adds. So I run a test print. Again I'm not even paying attention on if a test print comes out.

A few seconds later the printer fires up. I'm ignoring it at this point. Then it dawns on me what is happening. I go over to the printer and sure enough, CUPS test page...in black and white. I remember in the options there is a choice for color. I change it and try again. Prints a test page in color this time. (I later realize the choices in these settings are for setting the defaults. You still have all the same choices in a print dialog).

So test pages are fine and good, but if that is all it can print then what's the point. I pull open a document and print. Nothing. Then after a minute or two it fires up. full color and without a hitch.

Takes a bit of time apparently depending on the complexity of the document, but it works!

I go over to the G4 again and enter the same info into CUPS. Works the same!

Finally after almost a year the free color laser that came with brand new toner carts and that cost me a whole $50 for an oil roller is working just fine and I can do color proofs at letter or legal before committing it to ink.

Now I can cross that stupid project off my list once and for all!

Now I don't know that my exact settings (replacing my IP with your correct one of course) will work for you, but if you have a windows PC on your network that is using the printer just fine, you might check out the properties for the printer on that machine to see what it shows. Might help you get it working with what it shows there.

Anyway, hope this helps someone. Just didn't feel right sitting on the knowledge and not sharing it. :)


Edited 1 time(s). Last edit at 02/13/2009 09:14AM by rickrich.

Options: ReplyQuote
Re: Using 2200DL with OS X (May apply to Linux too)
Posted by: rickrich ()
Date: February 13, 2009 09:11AM

From the INSTALL file:
    Use the network interface if you can.  These printers understand Unix
    LPD printer server protocol.  So when setting up the printer queue,
    you can select "UNIX Printer (lpd queue)", set the lpd queue name to
    "lp" (arbitrary), and set the "Server" to the IP address of the

    These printers also understand several other printer server protocols,
    such as JetDirect and IPP, but I have not tried them.  In any case,
    I'm not aware of any advantages of using them over LPD.

Options: ReplyQuote

Sorry, only registered users may post in this forum.
This forum powered by Phorum.