Minolta-QMS magicolor 2200 DL :  foo2zjs - foo2hp - foo2xqx - foo2lava - foo2qpdl - foo2oak
Support for linux printer drivers
The fastest message board... ever.
 
Setting up 2200 in ubuntu 8.10
Posted by: PeskyJ ()
Date: November 15, 2008 10:02PM

I have compiled and installed foo2zjs as per the instructions and confirmed the freshly compiled version is in /usr/bin, restarted cupsd, etc. - however I can't get the printer working.

Ubuntu uses CUPS, and I don't even know if CUPS is selecting the foo2zjs driver because it never seems to ask directly which driver to use.

I get these options:
1: Pick Make+Model (Magicolor 2200 DL is not listed)
2: Use PPD file (This is the option I choose, selecting mq2200np.ppd that I got from the Minolta drivers site).
3: (In the GUI) search for drivers on the web (this produces no drivers to choose from).

Another thing, I don't know what to put for the device URI, I have tried:
socket://192.168.1.250:9100
socket://192.168.1.250:135
lpd://192.168.1.250
lpd://192.168.1.250/ps

First one seems the most obvious from the presented options, second one I tried as I vaguely remember the port was 135 under windows Crown drivers. the lpd:// ones are suggested in the CUPS help files.

None of these work, CUPS doesn't seem to do any communicating with the printer (through foo2zjs or otherwise, I have no idea).

Does anyone know how to set this printer up?

Thanks,
J

Options: ReplyQuote
Re: Setting up 2200 in ubuntu 8.10
Posted by: rickrich ()
Date: November 16, 2008 12:01AM

Enter "socket://<printerhostname>:35" as the Device URI, where
<printerhostname> is the hostname or IP address of your printer and
35 is the TCP port the 2200DL receives print jobs on.

eg: socket://192.168.1.254:35

Note: There are some references between the 2200DL and port 9100 on the
Internet. This is a valid port for other Minolta printers, but
NOT the 2200DL.

Select the make of your printer. This is "Minolta" for the 2200DL
Select the model of your printer.

Options: ReplyQuote
Re: Setting up 2200 in ubuntu 8.10
Posted by: PeskyJ ()
Date: November 16, 2008 06:08PM

Excellent, thanks. That setting works for printing the test page. However, now when I print an image out, the printer does nothing.

I have tested printing text files and web pages (with images in them) and they print out fine with no problems. However when I try to print a JPG file (from either GIMP or from the image previewer) the printing appears to work correctly on the PC side - the job gets added, processed and sent to the printer, then is gone.

During this, the printer displays "Processing..." then just goes straight back to "Idle" without actually printing anything.

The image is quite large (almost a full A4 sheet), I have tried in monochrome, colour, with the image converted to grayscale/rgb, I have tried changing the print size parameter in GIMP to set different resolutions. Any idea what is happening and how to get this working?

Thanks,
J

Options: ReplyQuote
Re: Setting up 2200 in ubuntu 8.10
Posted by: PeskyJ ()
Date: November 16, 2008 06:26PM

Hrm, as a last-ditch effort to print this image, I opened up photoshop (which I have installed in Wine) and printed it from there, to my surprise, this worked!!

I noticed that in the "Document" column of the print jobs monitor it said "(stdin)".

Perhaps something is broken in the way ubuntu/gnome communicates to CUPS, but it still works the way Wine does it, which is presumably through pipes? Could this be a result of installing the source version of foo2zjs and the install script not doing some ubuntu-specific configuration step?

Any ideas appreciated :)
J

Options: ReplyQuote
Re: Setting up 2200 in ubuntu 8.10
Posted by: rickrich ()
Date: November 16, 2008 06:31PM

Please put the Postscript source for the image on the web.

Options: ReplyQuote
Re: Setting up 2200 in ubuntu 8.10
Posted by: PeskyJ ()
Date: November 16, 2008 09:33PM

I don't really know what you mean by the Postscript source, the image is a JPG file.

I found that by using the "print to file" option from the print dialogue in GIMP I can save it as a postscript file (25.2 MB). I also found that double-clicking the .ps file opens document viewer and if I select print from there, and choose the magicolor then it prints out fine.

Is this file what you want? Or do you want an interception of what GIMP sends to CUPS or to foo2zjs when I print it directly? I don't know how to do that. Or is the postscript source something else entirely?

J

Options: ReplyQuote
Re: Setting up 2200 in ubuntu 8.10
Posted by: rickrich ()
Date: November 16, 2008 11:58PM

Something is wrong with GIMP, then. All files are done in Postscript. File a bug report with GIMP.

Options: ReplyQuote
Re: Setting up 2200 in ubuntu 8.10
Posted by: rickrich ()
Date: November 17, 2008 12:08AM


Options: ReplyQuote


Sorry, only registered users may post in this forum.
This forum powered by Phorum.