General foo2hp :  foo2zjs - foo2hp - foo2xqx - foo2lava - foo2qpdl - foo2oak
Support for linux printer drivers
The fastest message board... ever.
 
Problem compiling dependency foomatic-filters
Posted by: AprilHare ()
Date: May 20, 2013 10:08PM

Hello,
I am attempting to compile foomatic-filters to use foo2hp and I get the follow error, similarly whether I use the version suggested in the OS X readme file or the latest version as below.
I went and installed http://waix.dl.sourceforge.net/project/macpkg/PkgConfig/0.26/PkgConfig.pkg but no difference was seen - it might not be in the path?
I tried installing foomatic-rip but no difference there either (it may not offer the filters?)
<snip>
checking for mpage... no
checking for texttops... no
file-converter: 
checking for pkg-config... no
checking for DBUS... configure: error: in `/tmp/foomatic-filters-4.0-20130520':
configure: error: The pkg-config script could not be found or is too old.  Make sure it
is in your PATH or set the PKG_CONFIG environment variable to the full
path to pkg-config.

Alternatively, you may set the environment variables DBUS_CFLAGS
and DBUS_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

To get pkg-config, see http://pkg-config.freedesktop.org/.
See `config.log' for more details.

Options: ReplyQuote
Re: Problem compiling dependency foomatic-filters
Posted by: rickrich ()
Date: May 21, 2013 05:54AM

Add "--disable-dbus" to the configure command.

$ CPPFLAGS="-I/opt/local/include" LDFLAGS="-L/opt/local/lib" ./configure --prefix=/usr --disable-dbus

Options: ReplyQuote


Sorry, only registered users may post in this forum.
This forum powered by Phorum.