is foo2hp 64 bit compatible? [hp2600n, Ubuntu]
Posted by: bytejunkie ()
Date: April 29, 2007 03:33PM

hey,

I'm new to ubuntu, about 2 weeks experience.

I need to get my 2600n working, or its gonna be a deal breaker.

I've downloaded the driver tarball, unzipped it to the folder, but when i try to run make in the folder, ir errors.

foo2zjs.c:60:19: error: stdio.h: No such file or directory
foo2zjs.c:61:20: error: stdlib.h: No such file or directory
foo2zjs.c:62:19: error: ctype.h: No such file or directory
foo2zjs.c:63:20: error: string.h: No such file or directory
foo2zjs.c:64:20: error: unistd.h: No such file or directory
In file included from foo2zjs.c:67:
zjs.h:9:22: error: inttypes.h: No such file or directory
In file included from foo2zjs.c:67:
zjs.h:10: error: expected ?=?, ?,?, ?;?, ?asm? or ?__attribute__? before ?DWORD?
zjs.h:11: error: expected ?=?, ?,?, ?;?, ?asm? or ?__attribute__? before ?WORD?
zjs.h:12: error: expected ?=?, ?,?, ?;?, ?asm? or ?__attribute__? before ?BYTE?
zjs.h:36: error: expected specifier-qualifier-list before ?DWORD?
zjs.h:246: error: expected specifier-qualifier-list before ?DWORD?
zjs.h:254: error: expected specifier-qualifier-list before ?DWORD?
zjs.h:259: error: expected specifier-qualifier-list before ?int32_t?
zjs.h:263: error: ?uint32_t? undeclared here (not in a function)
zjs.h:264: error: expected specifier-qualifier-list before ?uint32_t?
zjs.h:268: error: ?uint16_t? undeclared here (not in a function)


thats just the first 10% of the errors. pretty much every line is an error.

I'm really struggling to get ubuntu working with my peripherals, is it cos i've chosen the 64 bit version?

Matt



Edited 3 time(s). Last edit at 04/30/2007 08:58PM by rickrich.

Re: is f002hp 64 bit compatible?
Posted by: rickrich ()
Date: April 29, 2007 04:12PM

From the INSTALL file:
UBUNTU NOTES
------------
    Install build-essential FIRST:
        $ sudo apt-get install build-essential
        $ wget -O foo2zjs.tar.gz http://foo2zjs.rkkda.com/foo2zjs.tar.gz
        $ tar zxf foo2zjs.tar.gz
        $ cd foo2zjs
        $ sudo make uninstall
        $ make
        $ ./getweb 1020
            OR other printer
        $ sudo make install install-hotplug cups

Re: is f002hp 64 bit compatible?
Posted by: bytejunkie ()
Date: April 29, 2007 05:42PM

wonderful, thats allowed me to install the driver.

can't print in colour though, any ideas?

Matt

Re: is f002hp 64 bit compatible?
Posted by: rickrich ()
Date: April 29, 2007 06:36PM

$ sudo gnome-cups-manager
Configure HP 1600/2600n with Color Mode equal to "Color".

Then, do this on Ubuntu ONLY:
$ sudo make cups
gnome-cups-manager has a bug in it.

Re: is f002hp 64 bit compatible?
Posted by: bytejunkie ()
Date: April 30, 2007 03:39PM

reinstalled from scratch but it refuses the colour print...

Matt

Re: is foo2hp 64 bit compatible? [Ubuntu]
Posted by: bytejunkie ()
Date: April 30, 2007 04:36PM

ignore me, its working in word. must just be the test page that doesn't print in colour.

Matt

Sorry, only registered users may post in this forum.
This forum powered by Phorum.