Printing offset [ # lpoptions -o media=A4 ]
Posted by: bwalle ()
Date: January 01, 2007 05:59PM

Hello,

I have this Konica Minolta magicolor 2430 DL printer (how can I get out the firmware version?) and printing with your driver works fine, except there's an offset. I figured out how to "correct" this offset using the script at http://www.linuxprinting.org/download/printing/alignmargins.

However, the weird thing is that this offset is not always constant. It's different in portrait and landscape mode (nothing changed in the CUPS setting, only printing a Landscape document from OpenOffice) and I also had PDF documents where the default settings is right.

The strange thing is also that the vendor driver has the same behaviour. Maybe you and Minolta tested only with US Letter and not with ISO A4?

Can you point me where the offset must be changed in source code? Or any other hints are appreciated. :)

I created now two PPD entries with offsets (and the default), and one of them is always correct. But it's annoying to have to remember which setting is correct for a specific document type.


Regards,
Bernhard



Edited 1 time(s). Last edit at 07/26/2007 04:47AM by rickrich.

Re: Printing offset
Posted by: rickrich ()
Date: January 01, 2007 06:13PM

From INSTALL:
SET DEFAULT MEDIA WITH CUPS
---------------------------
    $ sudo
    # lpoptions -o media=A4
        -OR-
    # lpoptions -o media=Letter


Re: Printing offset
Posted by: bwalle ()
Date: January 02, 2007 02:21PM

That seems to solve the issue. I thought it's enough to set the paper size to A4 in kprinter. Yes, I should not think but read the manual. :-/

Thanks a lot!

Sorry, only registered users may post in this forum.
This forum powered by Phorum.