Minolta-QMS magicolor 2300 DL :  foo2zjs - foo2hp - foo2xqx - foo2lava - foo2qpdl - foo2oak
Support for linux printer drivers
The fastest message board... ever.
 
Translation needed for Install.osx
Posted by: PlasticMoonRain ()
Date: April 10, 2011 05:46PM

I have Magicolor 2300 DL and a Mac running 10.4.1.

I have followed this document as far as downloading and installing the software it requires.

However, there are parts of this document I do not understand, or the instructions are just not clear enough. I am an average Mac user.

I have no idea what this means in the document...

Do:
$ export PATH=$PATH:/opt/local/bin
$ sudo port selfupdate
$ sudo port install coreutils
$ sudo port install wget
$ sudo port install ghostscript



What is that? Where do I do it? How do I do it?

And this...

$ wget [www.linuxprinting.org]
$ tar zxvf foomatic-filters-4.0.5.tar.gz
$ cd foomatic-filters-4.0.5
$ CPPFLAGS="-I/opt/local/include" LDFLAGS="-L/opt/local/lib" ./configure --prefix=/usr
$ make
$ sudo make install



Don't know what that is either.

Can you please clarify what all this means so an average person like me who has a Mac and a Magicolor 2300 DL can figure this out and hopefully start printing.

THANKS.

Options: ReplyQuote
Re: Translation needed for Install.osx
Posted by: rickrich ()
Date: April 10, 2011 06:21PM

Use:

Finder -> Applications -> Utilities -> Terminal

Options: ReplyQuote
Re: Translation needed for Install.osx
Posted by: PlasticMoonRain ()
Date: April 11, 2011 01:10PM

And is that from the administrator's account on the Mac? Or does this work from any account on the computer?

THANKS.

Options: ReplyQuote
Re: Translation needed for Install.osx
Posted by: rickrich ()
Date: April 11, 2011 01:32PM

Why don't you try it and find out????

Options: ReplyQuote
Re: Translation needed for Install.osx
Posted by: PlasticMoonRain ()
Date: April 11, 2011 04:43PM

I will.

I have not been lazy at all in working on this.

But as I was hoping for helpful guidance, you know? I get all the sarcasm I need on the NY subway,

Options: ReplyQuote
Re: Translation needed for Install.osx
Posted by: PlasticMoonRain ()
Date: April 11, 2011 08:20PM

I installed Xcode 2.5 (I use Tiger). I installed MacPorts 1.9.1 for Tiger.

But I'm not getting anywhere with step #3. I pasted those instructions into the terminal from my administrator's account and here's what I am getting (xxxx = my name)...

$ export PATH=$PATH:/opt/local/bin
tcsh: Bad : modifier in $ (/).
$ sudo port selfupdate
$ sudo port install coreutils
$ sudo port install wget
$ sudo port install ghostscript[new-host-2:~] xxxx% $ sudo port selfupdate
tcsh: $: Command not found.
[new-host-2:~] xxxx% $ sudo port install coreutils
tcsh: $: Command not found.
[new-host-2:~] xxxx% $ sudo port install wget
tcsh: $: Command not found.
[new-host-2:~] xxxx% $ sudo port install ghostscript

Options: ReplyQuote
Re: Translation needed for Install.osx
Posted by: rickrich ()
Date: April 11, 2011 08:47PM

You need bash, NOT tcsh!

http://macdevcenter.com/pub/a/mac/2004/02/24/bash.html

$ chsh -s bash



Edited 2 time(s). Last edit at 04/12/2011 09:06AM by rickrich.

Options: ReplyQuote
Re: Translation needed for Install.osx
Posted by: PlasticMoonRain ()
Date: April 15, 2011 08:54PM

Doesn't seem to want to change shells.

I put the command above in the terminal and it reads:

-bash: $: command not found

Options: ReplyQuote
Re: Translation needed for Install.osx
Posted by: PlasticMoonRain ()
Date: April 16, 2011 10:21PM

OK -- we've figured things out because, well, specific instruction are not in install.osx and they need to be added so dumb people can perform these tasks. It was some frustrating trial and error but we found our way.

So please add these to the document so others won't be lost...

* not using the $ symbol in terminal.

* it should be in bash (and how to get to bash if you're not).


Now we are up to step #5. And the wget command is being rejected repeatedly. I'm getting this in my terminal:

-bash: wget: command not found

Since that command was not working, I clicked the link, and downloaded the file foo2zjs, then unpacked it using my Mac's unzipping program. However, none of the Unix commands seem to make the next steps of compiling and installing work.

How do I compile and install foo2zjs?


THANKS.



Edited 1 time(s). Last edit at 04/17/2011 12:31AM by rickrich.

Options: ReplyQuote
Re: Translation needed for Install.osx
Posted by: rickrich ()
Date: April 17, 2011 12:29AM


$ export PATH=$PATH:/opt/local/bin
$ sudo port selfupdate
$ sudo port install coreutils
$ sudo port install wget			#IMPORTANT !!!!!!!!
$ sudo port install ghostscript

$ wget -O foo2zjs.tar.gz http://foo2zjs.rkkda.com/foo2zjs.tar.gz
$ tar zxf foo2zjs.tar.gz
$ cd foo2zjs
$ make
$ ./getweb 2300
$ sudo make install

Options: ReplyQuote
Re: Translation needed for Install.osx
Posted by: PlasticMoonRain ()
Date: April 17, 2011 10:29PM

Great -- thanks -- that all seems to have gone fine (and should probably be added to install.osx too).

Browsed http://foo2zjs.rkkda.com/cups/2300dl.html and all the settings look fine. Seems like everything installed just the way it should.

Went to http://localhost:631/ and I am stuck on the username/password part. I am putting in the exact name and password I use logging in as administrator, and it keeps rejecting that.

According to http://foo2zjs.rkkda.com/cups/2300dl.html, if asked for a username and password, I enter my "login username or password or the 'root' username and password."

What am I missing that it is not letting me use my username or password?

And once I am in there, do I go to Manage Printers and Add a Printer, or is my printer already in there? Do I download CUPS software? Once this username/password problem is figured out, what is next -- what are the "CUPS instructions?"

THANKS.

Options: ReplyQuote
Re: Translation needed for Install.osx
Posted by: rickrich ()
Date: April 17, 2011 11:10PM

I put in my username (rick) and password (censored). But, this is CUPS, you should find out from Apple!!!!

Options: ReplyQuote
Re: Translation needed for Install.osx
Posted by: PlasticMoonRain ()
Date: April 18, 2011 10:22PM

OK, I got in.

I added my printer. I assume it was the Magicolor 2300 DL, as that is the printer I have? They sure do give you lots of choices.

I clicked on print test page -- nothing happened.

Does this mean I should have put in a different Magicolor printer driver? How do I know this is connected now after all the installations and time I've put into this?


THANKS.

Options: ReplyQuote
Re: Translation needed for Install.osx
Posted by: PlasticMoonRain ()
Date: April 18, 2011 10:33PM

I'm toying around with this.

This printer is not networked -- it is just connected to this Mac.

Is there a problem connecting to the printer with a USB cable?

According to the install.osx document, there are instructions for the 2200SL -- I have the 2300DL. Should I follow those special instructions too, even though it's not the same model?

Am I going to need the IP address for this printer to make it work?


THANKS.

Options: ReplyQuote
Re: Translation needed for Install.osx
Posted by: PlasticMoonRain ()
Date: April 18, 2011 11:04PM

Getting a steady diet of this error message:

"The process "foomatic-rip" stopped unexpectedly with status 1"

Options: ReplyQuote
Re: Translation needed for Install.osx
Posted by: rickrich ()
Date: April 19, 2011 01:27AM

Did you do step 4???


$ type foomatic-rip
foomatic-rip is /usr/bin/foomatic-rip

$ type gs
gs is /opt/local/bin/gs



Edited 2 time(s). Last edit at 04/19/2011 01:45AM by rickrich.

Options: ReplyQuote
Re: Translation needed for Install.osx
Posted by: PlasticMoonRain ()
Date: April 19, 2011 10:31PM

Yes, absolutely did step #4. foomatic is one of the printer choices under Minolta.

Double checked there were there as yo write, and they were.

When I go into http://127.0.0.1:631/, and have to set up the printer, and it comes to the screen where you pick the device, I assume the choice is Magicolor 2300 DL, right?

And the next screen, where it asks you the Make, you click on "Minolta," right?

And the printer you choose is the Magicolor 2300 DL, right?

It's not even printing out the test job. Still reads: "The process "foomatic-rip" stopped unexpectedly with status 1"

I have this also listed with the printer: Device URI: usb://MINOLTA-QMS%2cPJL/magicolor%202300%20DL?serial=0

Options: ReplyQuote
Re: Translation needed for Install.osx
Posted by: rickrich ()
Date: April 20, 2011 05:39AM

I used the network connection to 2300DL, not USB.
$ ssh mac
Last login: Tue Apr 19 00:35:15 2011 from dual

$ cd foo2zjs

$ foo2zjs-wrapper testpage.ps > xxx

$ ls -l xxx
-rw-r--r--  1 rick  rick  100420 Apr 20 04:31 xxx

$ lpstat -a
...snip...
km2300dl accepting requests since Tue Apr 19 05:44:22 2011

$ lp -d km2300dl -o raw xxx
request id is km2300dl-51 (1 file(s))
{printed fine}

Also used USB (km2300dl-usb). Printed FINE.

I would say go to:
    http://localhost:631/admin
And click:
    Save debugging information for troubleshooting
then
    Server -> Change Settings.
Then run a:
    Maintenance -> Print test page

Then:
    http://localhost:631/admin/log/error_log

Save it and upload it to a web site that I can access.



Edited 2 time(s). Last edit at 04/20/2011 08:47AM by rickrich.

Options: ReplyQuote
Re: Translation needed for Install.osx
Posted by: PlasticMoonRain ()
Date: April 20, 2011 10:15PM

Rick:

On my admin page -- there is no button or ANYTHING that says "Save debugging information for troubleshooting."

I am mystified.

According to the title bar, I am using CUPS v.1.2.23.

Maybe that has something to do with it?

According to cups.org, the current version is 1.4.6. So I downloaded it. But I have no idea how to install it. There is an install.txt file that comes with it, but unfortunately, it's over my head. (Sorry)


THANKS IN ADVANCE.

Options: ReplyQuote
Re: Translation needed for Install.osx
Posted by: rickrich ()
Date: April 20, 2011 11:00PM

Upgrade to Snow Leopard. $29 from http://www.apple.com/macosx/

Options: ReplyQuote
Re: Translation needed for Install.osx
Posted by: PlasticMoonRain ()
Date: April 22, 2011 10:33PM

Can't do it -- this computer does not have an Intel processor.

Does this mean I can't install CUPS 1.4.6?

There's no other way of getting you this error log?

If 1.4.6 won't work with this Mac, is there another version I can download and install that will work and provide you with what you need?

http://www.cups.org/software.php


THANKS.

Options: ReplyQuote
Re: Translation needed for Install.osx
Posted by: PlasticMoonRain ()
Date: May 04, 2011 10:27PM

Rick:

It's been 10 days since you've responded to my queries to get my printer going.

Are you still there?

Options: ReplyQuote
Re: Translation needed for Install.osx
Posted by: rickrich ()
Date: May 04, 2011 10:55PM

Ping the CUPS person to install 1.4.6 on a PPC Mac running OSX 10.4.1.

Options: ReplyQuote
Re: Translation needed for Install.osx
Posted by: PlasticMoonRain ()
Date: May 05, 2011 09:05PM

Sorry, but who is the CUPS person? What do you mean "ping them?" Where?

THANKS.

Options: ReplyQuote
Re: Translation needed for Install.osx
Posted by: rickrich ()
Date: May 06, 2011 03:14AM

http://www.cups.org



Edited 1 time(s). Last edit at 05/07/2011 02:59AM by rickrich.

Options: ReplyQuote
Re: Translation needed for Install.osx
Posted by: PlasticMoonRain ()
Date: May 06, 2011 11:09PM

If you are talking about www.cups.org, well, that's definitely in the ballpark. But I don't see anybody on the site ID'd as "the CUPS person."

Are you suggesting to post something in the forum there, or is there a real "CUPS person" I should be contacting, as you say?

THANKS.

Options: ReplyQuote
Re: Translation needed for Install.osx
Posted by: PlasticMoonRain ()
Date: May 07, 2011 02:35PM

Rick:

I see you edited your post about the web site -- but it would really be helpful if you could answer my question.

Who is "the CUPS person?" Or are you talking about posting in the forum?

THANKS.

Options: ReplyQuote
Re: Translation needed for Install.osx
Posted by: rickrich ()
Date: May 07, 2011 02:52PM

forums.

Options: ReplyQuote


Sorry, only registered users may post in this forum.
This forum powered by Phorum.